Oculus Quest 2 and Quest
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Air Link Help (Oculus Quest 2)

I kept thinking if the Oculus Quest 2 can use a USB with a charging cable on it for Air Link.I have tried that, but nothing helped.During use, I thought it would work from going onto air link in my Quest 2 and enabling air link.I need some help from ...

Air Link Wont Work!

Ok, so I'm trying to get into air link right? But whenever i press launch, there are 3 loading dots. and when the loading is over,it takes me back to the oculus home screen. And, I get a message when trying to launch...

Screenshot 2021-05-03 190453.png

oculus hardware/software

My pc was compatible with the quest 2 and after a recent update its no longer compatible. how does that happen. My pc runs a AMD Radeon RX5700 XT and a AMD Ryzen 3700x 8-Core Processor, 16gb Ram. how its this not compatible with it. it worked before....

SnowWuff by Explorer
  • 7 replies
  • 0 kudos

Oculus link problems on pc

Yo so i just bought the official oculus cable for the quest 2 and i cant get it to work. Only half of the time it connects and other times it stays connect until i try to play a game. I know for a fact it doesnt have anything to do with my pc, im sim...

Kousgaard by Honored Guest
  • 0 replies
  • 0 kudos

Netlimiter and Airlink

I've only started using Netlimiter Pro 4 to try and make Airlink as efficient as possible. The only thing is that I really don't know what I'm doing and have only succeeded in making performance worse. I'm kinda retarded and would like some suggestio...

Help Please with New OQ2

I recently picked up a OQ2 because samsung stopped supporting the Rift that I had which I absolutely loved. The OQ2 is fine ... but I doesn't seem to be able to do any of the things that the Rift could because the Rift really worked off of the phone ...

Anonymous by Not applicable
  • 9 replies
  • 0 kudos

Quest 2 and Link not working

Okay. To cut it short; my PC recognizes my Quest 2 is plugged in. I saw it recognized via Devices settings AND it was plugged in a 3.0 port. My settings said so! However, Oculus Link cant find my Headset and my PC isnt found if i enable link from my ...

Anonymous by Not applicable
  • 0 replies
  • 0 kudos