Get Help
Need a hand or looking to help others? Find answers and ask questions about your headset, accessories, and apps.
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! Known Issue: Quest 2 SystemUX Crashes when using App Tray/Browser

Hello all, I played some VR last night no issues woke up this morning to find some weird problems. Initiallt the issue was SystemUX keeps stopping, I tried clearing cache and storage for the app to no resolution. I then ran a headset factory reset. T...

Resolved! Known Issue - Meta Device Code Not Working

Everytime I have tried to add another accounts onto my quest 2 the device code on says "Invalid Device Code Request! Please try again!" I have factory reset my headset and done all troubleshooting methods.

Anonymous by Not applicable
  • 94 replies
  • 22 kudos

Contacting Meta Quest Support & Collecting Logs

Should you encounter an issue or have any questions that would require you to contact Meta Quest Support, you can do so by heading to the support page ( Here, you can contact the support team via email or liv...

How to Report a Bug

As with any software, sometimes you will come across unintended bugs or glitches. When you come across an issue with a Quest product, you may want to report it directly to our Engineering team. You can do so directly from the desktop or mobile app. B...


New User Posting Info

Being a newb in-game and in anything can be tough. Here is a run down of how our tiny forum elves (and moderators) can help get you from an unknown newb to forum all-star. Posting links to external sites, certain keywords, or posting logs outside of ...

Resolved! USB 3.0 issues with Quest 2

I see lots of similar posts about things surrounding this issue but they usually get brushed off, I am hoping that making this post and outlining what I have done so far it may finally prompt a fix. Essentially the issue is that when connecting with ...

Quest 2 guardian lag

Hello folks! Just the other day I've started having this issue where the whole quest system starts lagging whenever the guardian appears. This only seems to be an issue when the link cable is active and I'm in a game but when I'm checking the app tes...

Battery Drain While Using Oculus Link with Quest 2

I am using the official link cable plugged into a USB 3.2 port on my computer with a USB-C to USB-A adapter. During a 2 hour play session, the battery drained from 100% to 32% while plugged into link. At one point, I even got a low battery warning an...

Resolved! Quest 2 PC Link GTX 1080 Settings

So I thought I'd share my settings I have setup on my PC just in case anyone has a similar setup and is finding it difficult to get a decent image quality whilst preserving a stable framerate using Oculus Link. (I don't use Airlink/Virtual Desktop) M...

Oculusdebugtool.png graphics.png steamvrset.png
Lfanvr by Level 3
  • 7 replies
  • 8 kudos

Dark Layer over games When Using Link Cable

Hello, I've noticed when using The Link Cable for PC games on my Quest 2 there seems to be a dark layer over the games or at the home screen. This doesn't happen when using AirLink. Only when using the Link cable. I've tried multiple cables and the s...

Quest 2 Link cable crashing almost instantly

I'm having an issue where every time I connect my link cable to my quest, It will connect for a good 5 seconds before it crashes. I've tried 3 link cables and the Quest 2 software picks up that its connected, but it just can't link. Air link works fi...

ykJacks by Level 2
  • 1 replies
  • 0 kudos

Quest link not working, keeps showing me three dots

I recently got my Oculus and just received my link cable, when I plug the cable into my computer it shows on the oculus app that I am connected and active although when I go to hit the quest link in Oculus I am met with a black screen and three dots ...

Audio crackling - Link/AirLink

Most recent update here: Crackling noises are heard at certain sound frequencies when streaming via Link/AirLink. Especially human voices. The issue seem ...


Oculus Link with Quest 2

About a week or two ago, I've been having a recurring issue while using my Quest 2 to play PCVR games using the Link Cable. My frame rate is fine when I start up Oculus Link but as soon as the Oculus Rift Home loads in my frame rate drops to roughly ...

Link Lags when play with OBS

After updating to version 42, when playing through a link, it doesn’t matter whether it’s AirLink or a wired link, what are the settings, bitrate, screen frequency, resolution, it doesn’t matter, but there are very unpleasant and constant lags, ONLY ...

Awangl by Level 2
  • 4 replies
  • 0 kudos

V41 link stutter/lag

ever since the V41 update my friends and i have notice a lot of lag and stuttering when using a link cable with the quest 2. I've tried reinstalling the link app on my pc but there was no improvement. it has made most games unplayable for me as every...

Oculus link weird tacking issue

There's a weird issue I'm experiencing on my quest 2 link which can be seen in the video below. I'm not sure what exactly to call it but I'd guess it's tracking related. Settings are pretty much all default, 120hz is turned on for the quest 2 itself ...

Usb 2 working but not 3

Hi i had this problem widh my old pc to (same cable)i got a usb 3.2 cable and when i put it into usb 3 slot i get accsess data but not link.and som time ago i was able to "start" link but just had 3 dot loading screen forever.thank you in advance

Halblo by Level 2
  • 1 replies
  • 0 kudos

Resolved! GPU Compatibility

To cut the question short, for AMD GPU's are series past 6000 just not going to be supported from now on?Ill be attempting my first PC build and one of the main things that ive been stopping at is figuring out if a graphics card will work or not.On p...

oculus link not working quest 2

i got my quest back in september of 2021 and it was working fine until around last summer. basically what happens is i plug in my quest to my pc, the little box that says "do you want this device to access your files?" shows up, i press allow, and no...

Oculus Link Cable will not work

Hi everyone - have a bit of a problem. My Link Cable (new) will not work. Neither the PC or Quest 2 get any type of notification. The light on the side of the quest is orange. I'm baffled as to why it will not work. Air link is off - I've done a fact...

ALVR thinks I have Vive Wands instead of Touch Controllers

I've searched for this problem and it affects people with both Virtual Desktop and ALVR, and I'm experiencing it myself. I know these programs are unsupported by Meta, but there has to be some way to figure out what is going on. I've done just about ...

Connecting my quest 2 to the oculus pc app doesnt work

Hi guys I got a link cable and connected it to my pc and my quest 2, when I try connecting my quest 2 to my oculus app it just doesn't work, same for air link. No VR game works while connected even though it says its connected on my pc so I'm really ...

Windows 11 stutter link cable

Just a heads up that there's currently a bug (or issue) with oculus link and windows 11. It took me hours to find a solution, but one does exist. Hopefully if enough people have this problem then it can be patched quickly. On windows 11 21H2 stable, ...

Bizla by Level 4
  • 6 replies
  • 4 kudos

Resolved! Oculus link cable

I have an oculus quest 2 and an alright computer. I know that connecting a quest 2 to a pc with airlink has requirements like 8+ gb ram and stuff like that. My pc does not meet those and I was wondering if a connecting with a link cable has requireme...

PC won't connect to Oculus Quest 2

I am stuck at the Connect your Headset step in the oculus app, I have a GTX 1650 SUPER and I've updated the drivers with the oculus-drivers.exe. I am using the oculus link cable and it's plugged into a dedicated usb-c port in the PC since there wasn'...

aadri3 by Level 2
  • 0 replies
  • 0 kudos

Oculus Link Suddenly Not Working

SPECS: Microsoft Windows 10 Home, Processor Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz, 3408 Mhz, 4 Core(s), 8 Logical Processor(s), Installed Physical Memory (RAM) 16.0 GB, NVIDIA GeForce GTX 1050 Ti I have been using my 3rd party link cable for ages, ...