Get Help
Need a hand or looking to help others? Find answers and ask questions about your headset, accessories, and apps.
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Known Issue - V65 USB-C Debris/Water Warning

Not a solution - Marking for visibility Known Issue Hello everyone! I have observed that a significant number of users are still encountering the USB-Debris error even after the V64 fix was distributed to everyone. Consequently, I have taken the init...

LaserDisk by Meta Quest Support
  • 4510 Views
  • 36 replies
  • 2 kudos

New User Posting Info

Being a newb in-game and in anything can be tough. Here is a run down of how our tiny forum elves (and moderators) can help get you from an unknown newb to forum all-star. Posting links to external sites, certain keywords, or posting logs outside of ...

Resolved! Quest update button not doing anything ptc v66

Im on ptc v66 and I got the update for the official rollout of v66. When I click update the download progress pops up for a second and goes away. The button to update is greyed out and stuck “updating…” I’ve let it sit for quite a while. Reset severa...

remix826 by Explorer
  • 11097 Views
  • 143 replies
  • 24 kudos

Close universal menu

Hi,can anyone tell me how to close universal menu on quest 3,I am new to vr and am playing the epic rollercoaster,it keeps telling me to close universal menu to carry on playing game,I click the x in the corner and it closes the main menu but there i...

Resolved! Quest 3 stuck in Battery Saver Mode

So I toggled the battery saver mode 3 days ago and ofc it lowered resolution. I wanted to test the feature. So I toggled it on, saw the change, and then toggled it off. When I turned it off, the resolution stayed the same, the fovetated size stayed t...

dinkd by Honored Guest
  • 27661 Views
  • 227 replies
  • 18 kudos

Resolved! Meta Quest 3 has terrible graphics quality.

Hello everyone. I received the Meta Quest 3 headset on October 12th.Launched, updated the software.And I started playing games while connected via Oculus Link to my laptop.On October 12, 13, everything was just great. Half Life Alyx has a fantastic l...

640f1325ca5805e561ed286aa0d45893.jpg 5fa0530478567310ef7b6476719280a3.jpg
Anonymous by Not applicable
  • 47893 Views
  • 57 replies
  • 4 kudos

Meta Quest 3 Left Lens Scratched

Only had a Quest 3 for a couple of months and the left lens is scratched due to wearing glasses. How would I go about repairing this myself? Meta want £379.99 to send me a refurbished unit!

simsini by Honored Guest
  • 39 Views
  • 1 replies
  • 0 kudos

Live Streaming Floating Window

Hi all,Hope you are all keeping well. Quick question, when you go live on Facebook is there a way to pin or move the floating Live Now window out of the way? Love going live on my Quest 3 but the floating window is so annoying and takes up far to muc...

FPC76 by Protege
  • 29 Views
  • 0 replies
  • 0 kudos

Trying to update an app to its new beta version doesn't work

While trying to update into the new scripting beta of blade and sorcery nomad I've encountered a problem. Every time I have enabled it, it updates do the exact same version. This also caused another issue, where without even prompting an update, I'll...

Micaelous by Honored Guest
  • 239 Views
  • 3 replies
  • 0 kudos

Missing features after updating to V66

After the latest issues I have now V66 installes on my Quest 3, how do I know if all V66 functionalities are active? and why are some available and some not.... Meta Wrist button - Yes Playing Background Audio - ? Hiding apps in your library - No Spa...

Resolved! Quest3 error update space arizona sunshine 2

I bought Arizona Sunshine2 on my quest3, every update I can't istall because returns me an space error, but I've almost 60 gb free. My workaround is unistall and reinstall the game every time.Someone know hot fix it?

Home, Spachnachrichten und Bilder Teilen Problem in V66 mit Q3

Mit Version 65 und 66 funktioniert das Home beitreten nicht mehr auf der Q3. Spachnachrichten im Chatt, button ist auch weg. Mit der 66 version geht auch das Bilder teilen nicht mehr. Wie kann das nur sein solche Grundsätzlichen funktionen kaputt zu ...

Premium Bowing

I tried to use Premium Bowling on my old Occulus 2; I had changed to Occulus 3. Now I cannot use it on either headset. All other apps work. I get a message that my accoun

Cannot buy anything from meta store due to disabled payments

I'm an og rift user and when quest 3 launched I decided that it was time to upgrade. I was extremely excited to try it out when it arrived 2 weeks ago but to my disappointment, I was unable to buy anything from the meta store for it. Each time I alwa...

Gooey_ by Honored Guest
  • 1926 Views
  • 16 replies
  • 2 kudos

Unable to add payment method

I am from India, I have a debit card with international transactions on, I've bought from US with my card before, but for some reason, whenever I try to add my debit card to meta quest app, it says, "Unable to add payment method" I tried from paypal ...

How do I not record/cast passthrough on Quest 3?

I went from Quest 1 to Quest 3 and when casting/recording, instead of showing the B&W breakthrough it would just show a black 'void'.On Quest when in your home UI and switch to passthrough camera the casting/recording will record it as well. I don't ...

Getting "Unable to Send Gift"

Trying to send gift but getting the following error when using app. Unable to Send Gift, This person is unable to receive this gift. This could be due to their region, user restrictions, or other factors. Please select another gift." Using web site a...

Eternal fan...

So my MQ3 froze up today. And when I tried to do a hard reset...it made a sound that can only be described as "BZZZRT" out of the speakers and then shut off. Even though it's been powered off for over an hour, the fan is still going loudly and it won...

Quest 3 Link and Air Link not working.

So I have been spending the past 3 days trying to troubleshoot this stupid issue with Quest Link. I have updated the redistributables associated with it, I have REINSTALLED WINDOWS TWICE! I have uninstalled, reinstalled the Quest Link App, even remov...

All of my recordings and screenshots are tilted

Everything is clearly tilted a few degrees to the left. I'm certain that my head is level and I see things as being level in the headset, but then when I watch a video back everything is titled. It is very obvious in some games and it makes the video...

Jory by Honored Guest
  • 166 Views
  • 7 replies
  • 0 kudos

Stuck trying to upload ID for age verification. Please help!

How can I upload my ID I’ve had this account since 2020 and they’re saying now they’re going to suspend my account? Bizarre. I just updated to meta 3 and I tried to click on the ID link once and it froze, now it won’t come back no matter what I do. I...

Legonia by Honored Guest
  • 83 Views
  • 2 replies
  • 0 kudos

App Sharing not working for Q3 after deleting Q2

I had a Quest 2 with app sharing enabled (my wife plays a few titles), so of course the Quest 3 prompted me to disable app sharing on the device, and pointed me to the device management portion of the website. Since one of my Q2 controllers randomly ...

Beat Saber

I have beat saber on my quest 3 and on my phone it says I own it for the meta pc app but when I go to the app on my pc it’s nowhere to be found.

Known Issue - V65 USB-C Debris/Water Warning

Not a solution - Marking for visibility Known Issue Hello everyone! I have observed that a significant number of users are still encountering the USB-Debris error even after the V64 fix was distributed to everyone. Consequently, I have taken the init...

LaserDisk by Meta Quest Support
  • 4510 Views
  • 36 replies
  • 2 kudos

Não consigo usar a autenticação de 2 fatores

Precisei criar uma nova conta pra poder tentar receber ajuda... Estou tentando entrar na minha conta mas estou preso na autenticação de dois fatores, ele pede pra eu acessar o meu aplicativo do celular. eu mudei meu celular, como posso entrar na minh...

Labels