Get Help
Need a hand or looking to help others? Find answers and ask questions about your headset, accessories, and apps.
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! (Not Resolved) Known Issue - V62/63 USB-C Debris/Water Warning

v62 has a big problem with USB port sensor (found the very same issue on my Q3 and the one of my wife)... when used with an extension cable (even if it is a quality cable) from time to time star showing the debris-water warning message. Of course the...

New User Posting Info

Being a newb in-game and in anything can be tough. Here is a run down of how our tiny forum elves (and moderators) can help get you from an unknown newb to forum all-star. Posting links to external sites, certain keywords, or posting logs outside of ...

Quest 2 - Controller pairing issue

So, in December my wife bought the Occulus 2. In mid January my wife was using the system and noticed that the right controller battery was dying. She replaced it and we could never get the controller to pair. Contacted support through chat and now b...

BSOD OVRServiceLauncher

Hello -- I am experiencing BSOD events while connected to airlink and running MS Flight Simulator 2020. In the application events I see this error below. I have just DL's the Oculus software again, and selected repair to be pre-emptive. Please advise...

Screen flickering repeatedly

Whenever I try watching videos in the browser, every time I enter full screen it starts flickering every few seconds non-stop. I looked it up online and it seems that other people are having the same problem but there was no real solution. Any guesse...

Resolved! Extreme Bit Rate Drops [Air Link on Oculus Quest 2]

Hi everyone, Is anyone else suffering periodic extreme drops in bit rate when using Air Link? I've recently moved home and my wireless network has changed slightly, but I'm comfortable that it's not an issue with my WiFi.Before I moved, I could set t...

Alumian by Explorer
  • 11340 Views
  • 8 replies
  • 2 kudos

Quest 2 won't cinnect to home wifi

I suddenly can't connect my Quest 2 to my home wifi. I can connect it to other wifi with weaker signals, but not the home wifi with good signal. It just says 'Connected, no internet' when I try. I also tried reinstalling my oculus app and factory res...

Resolved! Bought 2 headsets, do we need to buy games twice?

Hi all, I’m new to VR and bought two oculus quest 2 headsets (one each for my wife and I). If we want to play the same games together, do I need to buy the same game twice, one for each headset? I read online that there may be a way to log into the s...

Shipping label still not sent after a month

I raised a ticket 30 days ago for a faulty elite strap with battery. Oculus support told me a shipping label would be sent within 3 business days so I could get it replaced. It's now been over 4 weeks and I still haven't received the label and Oculus...

My microphone randomly went super quiet!

hi, im using an oculus quest 2 recently and i'm really enjoying it. However, today, when i was playing recroom, my mic just went super quiet. i had to scream just for someone to hear me in the slightest. someone please help! this is not with oculus l...

azazel279 by Honored Guest
  • 2708 Views
  • 6 replies
  • 1 kudos

Oculus Quest 2 Right Controller not working/pairing

I've had my vr for about a year now (also had a year before but it broke so I had to get a new one) and I tried going on it today and my right controller could not be tracked, and now and again would not even pair. I bought new batteries to see if th...

liliaXD by Honored Guest
  • 1001 Views
  • 4 replies
  • 0 kudos

Dark Layer over games When Using Link Cable

Hello, I've noticed when using The Link Cable for PC games on my Quest 2 there seems to be a dark layer over the games or at the home screen. This doesn't happen when using AirLink. Only when using the Link cable. I've tried multiple cables and the s...

Air Link suddenly not working - potential fix

Like many people here, I've had an issue with air link not connecting recently, but have found something that resolved the issue (at least temporarily). It's not an absolute fix, but might provide some insight for someone to work out what's causing t...

New Oculus Quest 2

Hi, I just got the Oculus Quest 2 and it does not work - screen starts with "remove plastic" from your battery - the "universal menu" seems to not be working (oculus button does work na right controller) - controller is clearly not paired (it's worki...

Zet2008 by Honored Guest
  • 555 Views
  • 1 replies
  • 0 kudos

Oculus Quest 2 Charging problem

So my Oculus Quest 2 isn't charging, I played it until it's dead the other night so I thought nothing about it and put it on the charger, next morning I woke did some stuff came home to a non charge headset and it's still dead, I looked at the cables...

16287565549724581922328738747596.jpg 16287566087523506763593090083253.jpg

Oculus Link would not work on Windows VM

I am running a Windows VM on a MacBook Pro to run Oculus Link and use my Oculus Quest 2 but the Oculus app would not detect the VMware Graphics adapter. VM Graphics Spec -Device Name - VMware SVGA 3DManufacturer - VMware Inc.Chip Type - VMware Virtua...

Saphira25_1-1614464931325.png OculusLink.PNG
Saphira25 by Honored Guest
  • 2316 Views
  • 3 replies
  • 0 kudos

Resolved! Trouble with multiple Quest 2s

Alright, so the school i go to wants to buy about 13 Quest 2s. We currently have one. And they employed me to get some information about how this stuff works. I know a bit, i read some articles about how it works but i still dont know anything. So th...

MiFrylek by Honored Guest
  • 754 Views
  • 1 replies
  • 0 kudos

Cannot checkout in Meta Store.

Hello, for two days now I have been trying to buy Oculus Quest 2. Unfortunately I cannot proceed through checkout. Website tells me that my address is invalid and checkout button is disabled. None of the fields passed with negative validation, looks ...

Ph3n0m by Honored Guest
  • 1214 Views
  • 0 replies
  • 0 kudos

Factory Reset

'I have just recently factory reset my Quest 2 to fix a problem with my link cable, but when I tried to finish the setup, I was unable to since my left controller's broken (as well as lost). Is there any way for me to finish the setup without having ...

Can not connect Quest 2 to Oculus desktop app PC Link

Hi, I just bought Oculus Quest 2, I bought Oculus Link Cable as well. I really wanted to play some of the cool VR games as this is my first headset. I downloaded the Oculus desktop app, then when I try to connect my headset I am encountering many iss...

Cannot connect Oculus AirLink with computer to play vr games

I bought the Oculus to play games on my computer in VR. I cannot use Oculus AirLink to play anything including Oculus and Steam games like Half-Life Alyx. When I try to connect AirLink to my computer inside Oculus, it shows the loading 3 dots icon an...

Cant install anything (Windows desktop) support no help :(

Hi all, Have suddenly come across this issue whereby I can't install any apps at all on the Oculus/Meta Windows desktop app. I have notifications stating an update for a game is in the queue, and an update to the oculus app itself is in the queue, bu...

Oculus Quest 2 Right Controller Stuck In Place

When I try to move around my right controller it doesn’t work. I can rotate them, click buttons and everything, I just cant move them around. I can’t do anything but rotate them and click buttons.

JoooshD by Explorer
  • 8798 Views
  • 6 replies
  • 1 kudos

Oculus Quest 2 Blank Link Screen

Whenever I plug my Quest 2 into my laptop, all that I see is a blank screen. I plugged it into my friend's computer who also has an Oculus and it worked there but wouldn't work on my laptop when using the same cable. I have an HP Omen 15 and have uni...

oculus

i got a oculus for my kid last month and he plugged it into his pc and he tells me it wont connect to the pc and when he puts it on and try's to go into the store it shows "oops nothing is here" i bought it so he could play games with his friends and...

fn.god by Honored Guest
  • 441 Views
  • 1 replies
  • 0 kudos

MIC not working native in Oculus Quest 2

Hi. My MIC on my Oculus Quest 2 does not work. It ssems to be working - when i make a record with mic i have sound, it works. But in other applications like Bigscreen for example - nobody can hear me. I checked - i have priviliege and it turned on, i...

Petroniks by Honored Guest
  • 920 Views
  • 2 replies
  • 0 kudos
Labels