Get Help
Need a hand or looking to help others? Find answers and ask questions about your headset, accessories, and apps.
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Resolved! (Not Resolved) Known Issue - V62/63 USB-C Debris/Water Warning

v62 has a big problem with USB port sensor (found the very same issue on my Q3 and the one of my wife)... when used with an extension cable (even if it is a quality cable) from time to time star showing the debris-water warning message. Of course the...

New User Posting Info

Being a newb in-game and in anything can be tough. Here is a run down of how our tiny forum elves (and moderators) can help get you from an unknown newb to forum all-star. Posting links to external sites, certain keywords, or posting logs outside of ...

Can't access referral. Get told :COULDN’T ACCEPT REFERRAL

Hi, I've just bought the Quest2 and tried to accept the referral, but I just get a page that says "COULDN’T ACCEPT REFERRAL" but no further information. I have an old DK2 and my account hasn't been used in some time. I just bought the Quest2 after my...

cj7hawk by Explorer
  • 1444 Views
  • 2 replies
  • 1 kudos

Can't Proceed with Referral

My friend and I tried to get referral point, but something has gone wrong My friend sent me a link to referral and I accepted it, BUT he can't get the message that I accepted his referral code 1. Where can I check my referral status (i.e. to whom I a...

No rewards after using the referral program

Hi, I've recently refered my friend prior to him getting the Meta Quest 2. I've sent him my code a day before he got the quest, since I'm aware that you need to do this before him he first uses it (activating the device).After he registered via the l...

Labels