Unity VR Development
Share Unity VR development feedback, issues, and challenges here!
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Haptics SDK for Unity not working

I'm trying out the new Haptics SDK for UnityI want to test it by playing a single haptic, but when I use this script I get an error with no haptics (testing in Unity editor 2022.2.13, with Air Link to a Quest 2)Script:public class OculusHapticClipTes...

Resolved! Unity game frequenly launches to black screen

Hi, I am experiencing an intermittent problem with an Oculus Quest game that I am developing. When I encounter this problem, I am unable to do any development in the editor. I am using Oculus Link to quickly iterate. Essentially, when I launch the ga...

Connecting Bluetooth device to Quest 2

Hi Dev community.I would like to connect a Bluetooth device (not headphone or keyboard ) to my quest 2. Currently my app running on Unity engine.Does Quest 2 support this kind of scenario?Is there any documentation available how can I do that as a de...

Buffer-based Haptics are broken for Quest 2

Haptic controller vibrations are a crucial tool for creating game immersion. While simple "buzzes" (a constant vibration amplitude for a specified duration) can be serviceable, modern controllers allow developers to play custom waveforms through the ...

Unity 2017.4 LTS and Quest 2 Compatibility

Hi everyone, We have a Unity project built in Unity 2017.4 LTS. We released a Go and Rift version in the last 12 months. However, we now wish to create a Quest / Quest 2 port of the game. When looking at the current minimum specs ( found here: https:...

URP and Quest

Can I use URP on Quest, and if so, can you help me find the docs? While a veteran of the VFX industry, I'm a virgin with game dev and Unity. I have been trying to understand the different rendering pipelines in Unity, I like what I see in URP and I h...

Resolved! Testing without wearing headset?

Hi, I have a quest 2 headset and I'm learning to make a vr project in unity, but every time I make a change and want to test it I have to* put on the headset* and set up guardian boundaries again because it lost the guardian* and go back into oculus ...

Build and Run Fail/Hub Fail

Hi! I have a weird problem. All of the sudden my project won't build and run, and the Oculus Developer Hub won't open. I have tried uninstalling and re-installing several times, but all it will do is open as a white panel and never load. Strangely en...

dmz.rom by Honored Guest
  • 1 replies
  • 0 kudos

How to get Hand Joint Location from Hand tracking

Please point me into the right direction. Looking into the OVRPlugin code I can not find a way to get Hand Joint Location, seems like Oculus doesn't provide us with that data...is it correct? I can see that there is a root pose in OVRPlugin.HandState...

Quest 2-Unity In game controller tutorial/guide

I have spent hours and hours google searching and forum searching and maybe I just am not using the correct terms but I sure could use some direction. I am wanting to create an in game controller tutorial that shows the player the controllers and whi...

marv69pa by Honored Guest
  • 1 replies
  • 0 kudos

repositories.cfg could not be loaded - Warning

Greetings y'all!Simple but annoying issue I have after configuring my Unity project for Quest dev.I'm getting this constant yellow warning at the bottom of the editor that says "File (...)\.android\repositories.cfg could not be loaded." I'm way too n...

Xainath by Honored Guest
  • 1 replies
  • 0 kudos

AR Passthrough sample scenes in Unity

Hey, the new sample scenes with passthrough AR do not seem to work on my Quest 2. I've built them from a clean project on unity 2020.3.4f1 but I just can't get the passthrough overlay/underlay on my build. Any help appreciated. Did yall manage to run...

Resolved! Version Number

Hi, I'm having an issue with android version not updating. I'm developing an apk with Unity3D for the Quest and Quest 2. The first submission on AppLab came back with some feedback which I've addressed, and I tried to upload a new build for submissio...

Quest 2 controllers don't render anymore

I've updated Oculus Integration to version 25.0 and SteamVR to version 2.7.3 (sdk 1.14.15). Now everytime I use the [CameraRig] and OVRCameraRig prefabs, the controllers won't show up, neither map the corresponding inputs. Also, I think there was a r...

VitoSSC by Honored Guest
  • 2 replies
  • 0 kudos

Quest 2 - Force 3DOF for project

Hi, how can set the project I'm working on to 3DOF only?I disabled "Use position tracking" on the OVRCameraRig component, it kind of works, but the visual result is quite different from disabling "Tracking" on the device ( quest 2 -> Settings -> Devi...

Jepplen by Explorer
  • 0 replies
  • 0 kudos

Oculus Quest 2 Control EQ Sliders in Game

Hi everyone, Myself and one other person are developing an immersive music application for the Quest 2 using Unity and have run into an interesting problem. Currently we are building in Unity 2019.17.4 We have a canvas and set of sliders linked to EQ...