Showing results for 
Search instead for 
Did you mean: 

PTC for Quest v.39 Megathread

Community Manager
Community Manager

The Public Test Channel (PTC) for Quest and Quest 2 v.39 is starting to roll out today. Let's use this thread for collecting feedback on it. Share your impressions and let us know if you see any issues. Please make sure to also send in bug reports along with posting here if you notice anything wrong.


When sharing feedback, try to include as much detail as possible to help the team investigate.

Help others find great discussions and answers by adding kudos and marking solutions to your questions.
198 REPLIES 198

Ok, I think I have a "definitive" solution to the screen only showing the controller and playing the guardian music ( which happens when you restart or turn the headset off and on when the guardian is disabled ) on version 39.

I did a factory reset due to the above circumstances and I got my headset back. Turned it off and on with guardian disabled and back to the loop...

Did it again, enabled guardian mode ( which I hate btw ) and the headset is ok after going to sleep, after restarts and after turning it off an on.

Like the **bleep** that I am, I disabled the guardian ( again, hate this **bleep**, so annoying )and I forgot top reenable it and I did a restart because I was having problems with the air link connection not working and.... Back to being stuck.................

Then I tried these things:

1: Messing with the settings on the oculus app to see if there was anything that could reenable the guardian through there and I found nothing.

2: While messing with the settings, I have set and unlocking pattern just for the sake of it, the unlocking pattern was asked on the headset and that accomplished nothing ( or so I thought )

2: Went into Sidequest, clicked device settings and tools and ticked on Experimental mode and guardian settings.

And after a reset, it worked, after drawing the unlock pattern ( while pugged to the pc ) then from there, you just enable the guardian on the quest 2 settings and never, EVER turn it off ( because if you forget to turn it on again to turn off your headset you get back into the loop )

Now I tried messing with all of those settings again to see what actually helped the headset go into the main menu like it should, and I think the whole go into the Sidequest and enabling experimental mode and guardian mode do not make a difference.

What seems to make it go through the initial blockage, is just enabling a mother **bleep**ing pattern os the mobile app, and having the headset pugged into the pc, if I do those 2 things and after drawing the pattern inside the headset a new message appears as follows.

Enable Oculus Link

Access Rift apps while your quest is plugged into your PC. You can enable/disable this from Quick Settings at any time.

Then 2 options appear below the message: "Enable" and "Not Now"  and below that there is a "Don't show again" option also.

At this point it doesn't matter what options you click, but I would suggest not clicking on the "Don't show again" as this pop-up might be the entire reason why the headset is going back to the menu at all.

I am sorry for the bible that I just wrote, but that is what I found so far and it seems to help.


TLDR: Seems to be: enable an unlock pattern on oculus app on your phone ( whick enables the pattern on the headset ) turn off the headset, plug it on your pc, turn on the headset, draw the pattern and select any of the 2 options regarding enabling the Oculus Link. and you should be back to the main menu. After this enable the guardian in the settings inside the quest 2 by going to: Settings, System, Developer and ticking on the Guardian option.

Phew, hopefully I can help some of you out there. ( If you want you can send this message to the occulus support team if you want, I am tired of these a holes )


edit: I did some more testing, and it seems that even after I disabled the guardian inside the quest settings by going to these options:  Setings, System, Developer and ticking off the Guardian option; the Guardian "state" shows as roomscale for me when I click on the square box on the left showing the time, battery percentage and wi-fi status but it is actually not getting in the way, because I didn't draw the roomscale thing that it asks for when you enable it, and by going to: Setings, System and Developer, the guardian settings is still set to off.

So, just to make sure, I did a restart just now, drew the pattern and it didnt ask me to set the guardian and it is just like I described above. The key seems to be the pattern drawing by the looks of it.

I think that is all for now and sorry if I mistyped something as english isn't my main language ( I am from Brasil ) and I type looking at the keyboard, LUL so I probably mistyped something somewhere, but I don't feel like checking/correcting it right now. Feel free to share this on any posts about these problems that you all may find as I am not versed enough to find the main sites/apps that people posts usually about those problems.

C ya.

Level 3

Since the Quest 2 automatically installed this update I can't control the refresh rate anymore. It is hard locked to 72hz and all options to change that are gone. Doesn't matter if it's native on the Quest 2 or using airlink. Everything is locked to 72hz. Also the screen sometimes stays black. This update absolutely made things worse. It's horrible.

Level 2

The exact same thing happened to me.
Got home and my headset was updating, went to play Eleven Table Tennis (where the frame rate is important for better reaction time) and was locked at 70.
Got out of the game and go to the headset settings and no more 120hz experimental options, conected my pc with link to try and see my grafic options and only had 72hz.


At 9 of march i lost my games due to a server issue for 11 days, now this, what are oculus/meta people doing ?!

They released this update even after seeing this... Guess nobody reads here. I lost all my data because of this.

Level 2

Fix for “Guardian” Bug

My Details : I only use the headset for a meditation app so my overall experience is limited.  Last night I found that I could only see visuals of my hand controllers and hear a space age music.  After many reboots, hard resets and button combos I posted on Reddit asking for help and went to bed.


My Settings Before this : Since it’s hard to use a meditation app from bed with guardian, I signed my company up for a developer account and disabled it long ago.  


My Fix Variation : before heading to bed one Reddit user suggested a factory reset and though I performed one holding the volume down button and power button at the same time while the unit was in a powered off state, it brought me back to the same issue and as a result I do not know if this intentional factory reset may have been needed.


After the factory reset I had to use the iOS app to re-pair the unit and begin setup.  As noted above, after I did this it rebooted and brought me right back to the same issue.


I then opened the iOS app again to see it still asking me to finish setup.  Once I clicked the option to finish setup again, I was alive and well.


Note that I didn’t have to intentionally disable guardian and in fact it was already reenabled after that factory reset.

Level 2

Does the v39 update support the original quest 1? Or is this a quest 2 only update?

Level 3

For those with refresh rates missing, I received a response this morning from support and was told, "I have been advised that there is an update coming soon that should be resolving this issue." Just making this post to inform those with this issue.

Hey DrGibs! The v39 update is also on the original Quest 1! The update will rollout to all devices over some time, and you can check to see if you have an update by following the steps outline in the article linked here: How do I update my Meta Quest 2 or Meta Quest software? We hope this helps! 

Level 4

Fix the 72hzs problem !!!!

Level 2

Is there any time estimate of how long will it take to solve the 72hz lock ?