Showing results for 
Search instead for 
Did you mean: 

Air Link "Searching for Computers....." Permanently - no results, no errors.

Level 3

Yes I have the Oculus PC App open with Air Link selected. 

Yes I have tried rebooting headset and PC.

No there is nothing wrong with my network, it is PC > Router (via ethernet) and headset is connected to that router. It works flawlessly with Virtual Desktop.


What else can I try to get it working? I've tried several times, left it for long period and it does nothing.




Level 7


Level 4

still no solution?

Still nothing on my end, Updated to PTC v29. Still doesn't work. 

Level 2

got the same issue, i guess we gotta stay with virtual desktop until oculus fixes this issue with airlink

Level 2

i was having the same issue and was able to get it to connect. went to devices in oculus app on pc and went to set up connection. went to airlink on oculus and instead of clicking on the name of my pc which always gave me the constants searching for pc non-sense, while my pc name was there, i instead clicked pair and it finally continued with the pair and i was able to get it connected