Showing results for 
Search instead for 
Did you mean: 

Air link won't give me pairing numbers

Level 2

I've used air link in the past and it has worked and i have the correct requirements on my pc and also have everything updated and good enough wifi, despite all of that now when i go to pair my oculus to my pc it shows up but when i click pair it greys out and does nothing further i get no pairing number, ive reset multiple times and ive even factory reset what do i do?


Community Manager
Community Manager

Hey Comocomster! We noticed you were having some Air Link pairing issues as it doesn't show the pairing numbers. We'd love to help out! 


Just to confirm, you do meet the Air Link best practices


Also, there is a current issue with AMD driver 22.5.2 and we would suggest to revert to 22.5.1 with the following steps:


  1. Go to this website:
  2. Select your graphics card using the drop-down menu of the product list and click "submit".
  3. On this page, scroll down and select "Previous Drivers".
  4. Here you can select your OS and find the 22.5.1 driver and and download.


If those don't partake to you or seem to help, feel free to reach our support team here where we'd love to provide further assistance! 

You say to search for my graphics card on there but on that site I have to put in my processor, I have a AMD Ryzen 7 3700X and there wasn't an option to look for previous drivers. also yes of course I meet the air link best practices. since there wasn't a "22.5.1" driver and when I tried to search for that specific driver nothing came up. Problem still isn't solved.