Showing results for 
Search instead for 
Did you mean: 

Also with the 3 dots...

Honored Guest

Hello,#Rift-S, #3Dots, #Not-Loading

Our Oculus Rift S has stopped working. We get the app to show the USB and the Headset are connected, But, the VR screen only shows 3 dots scrolling. And either a red or white light between the lens. I saw a post from Sept that your only current fix is to replace the headset. Here is the link to that solution.

Is this still the only option.
The Rift S was working great, then Sunday afternoon (10/10/2021) it stopped working after downloading/installing Beat Saber game from Steam.

We have uninstalled Beat Saber, Uninstalled/ reinstalled the Oculus software, all with the same result.

Disconnect/ reconnect PC side USB and Display cable.
Disconnect/ reconnect Headset side cable

Also has the same result.

We are re-installing the Oculus app again now, We'll add screenshots after the install has finished.


Gabriel Hobbs





Community Manager
Community Manager

Hi Gabriel thank you for bringing this to the community. We understand how inconvenient this is to you and we would love to help! The issue you are having could be caused by various reasons let's do some troubleshooting to see it is one of the common ones. After following all the steps below and your system still does not work please submit a support ticket here. Kindly include in your support ticket all of the troubleshooting steps that you have taken. 


Confirm if your computer still meets the minimum requirements for the Oculus Rift S:


Graphics Card

Recommended Specifications

  • NVIDIA GTX 1060 / AMD Radeon RX 480 equivalent or greater

  • NVIDIA GTX 970 / AMD Radeon R9 290 or greater

Minimum Specifications

  • NVIDIA GTX 1050 Ti / AMD Radeon RX 470 or greater

  • NVIDIA GTX 960 4GB / AMD Radeon R9 290 or greater


  • 8GB+ RAM

Operating System


The Rift S requires Windows 10.




The Rift S requires the following CPUs:

Recommended Specification

  • Intel i5-4590 / AMD Ryzen 5 1500X or greater

Minimum Specification

  • Intel i3-6100 / AMD Ryzen 3 1200, FX4350 or greater

USB Ports

The Oculus Rift S requires at least one USB 3.0 port.

  • Confirm that you're running the most up-to-date version of Windows 10. You can do this by selecting check for updates from your computer's system settings.

  • The most up-to-date USB driver should automatically be installed with the latest version of Windows


Confirm how the headset is connected, making sure that the headset and primary monitor are connected to the same video card:

  • Is an adapter or cable extender being used? If possible, remove any adapters from the headset. If the PC does not have enough of the needed ports (HDMI for Rift, Display Port for Rift S) and an adapter is needed, it is recommended to use the adapter with the monitor instead of the headset whenever possible.
  • If you do not have the needed port on the video card at all, for example: the AMD R9 295X2(No HDMI port), and adapter will be needed. There is For Rift: A compatible adapter that can be purchased from Amazon. The Rift S will come with a display port to mini display port adapter.
  • Disconnect the headset cable from the PC and from the headset and inspect it for and damage:
    • Bent Pins
    • Frays
    • Twists
    • Kinks
    • Etc.
      • Note: When reconnecting to the PC you should connect the USB cable first, then the display port cable to the dedicated graphics card.
  • Update graphics drivers
If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


I also have this problem. I have spent 10+ hours in the last month trying to contact Oculus and fix my headset. It does not look damaged, I have thoroughly cleaned the headset, I have the right specifications, I am up to date on everything, and have tried all other troubleshooting techniques. Please help.

Have you found any solution. I just put mine on and the Oculus program shows that all is connected and ready to go but all I see on the headset is the remotes and 3 dots. Please let me know anything you discover!