Showing results for 
Search instead for 
Did you mean: 

Any chance of solving the dreaded error 4107 ??

Level 2
On gear vr, the prime vr app works okay for a short period then opening movies is prevented by continuous 'page cannot be loaded....connection error....error 4107' type messages.
Sometimes just hitting retry a few times is enough. But mostly, after numerous retries, and the 4107 box repeating itself, i just quit and reinstall prime vr.
This is a temporary solution as the error box soon returns.
What is being done about solving the issue?
All other video vr apps i have including Netflix do not bring this problem.

Level 3

I had this on an Oculus Quest 2 yesterday. It's easily solved by deleting the Data rather than uninstalling the app. I did both - deleting the data first, then reinstalling. This means re-inputting login data of course. The route to Amazon Prime VR data is Settings/storage data. 

I can confirm this fixed the issue for me.  Thanks for posting

randleog's fix did only partially work for me. I managed to watch a show.
But downloading doesn't work. And if I try to go to my settings (the upper right-button) and click on... almost anything, I still get a long loading time and then a 4107.


Confounding factors:
I am German using my account in Germany with a Quest 2.

Maybe that's related?

Hey David, 


Using a German Amazon account on the Quest 2 should not be a problem. Please try to contact Amazon support about the issue, and ask if the Error is known and if they have a Workaround for it.


You can reach the Amazon support here:

Found a fix for this, the permission to datastorage must be enabled and vola

Hi - Thanks for this. Do you mean enable view of hidden files viewed on a PC connection? Most non-techie people will find it easier to delete all the data files from within the Oculus interface since the problem usually arises because of a corrupt cache file.

ame problem "Error message 4107"


Here's what I've already tried:


- Quit App and restarted VR and tried again

- Deleted app data and tried again

- Changed app permissions (granted access to VR) and tried again

- Uninstalled app completely and reinstalled and tried again


Nothing has helped. Another idea?



Level 3

Hmmm. I was working the same error message on the Oculus Quest 2, but the principle should be the same. I think I had corrupt files in the hidden folder, but it was enough to delete the app data, then as an additional step delete the app and then reinstall, and this worked. On the Oculus Quest 2 it's possible to access, and if necessary, delete the files in hidden folders via the PC link. First you have to know how to view the hidden files on a linked PC of course.

@randleog can you write me how this works?