Showing results for 
Search instead for 
Did you mean: 

Beat Saber v1.24 won't reinstall

Honored Guest

I have played beat saber for about a year now and gone through many updates, but one times it stopped updating saying "Download Failed" stopping at about 84 kbs, I have no external games or mods, haven't even accessed the Oculus with a computer. Since it stopped updating I decided to try to uninstall and reinstall and it hasn't been working.


Honored Guest

Also since I can't figure out how to edit a forum post I will add this here and hope people see it.


I have tried hard resetting, different networks, working networks, downloading other games, downloading other content, and am thinking about connecting it up to a computer and manually deleting all contents of beat saber 

Hey there, @BOSS2342! We see you're having issues with Beat Saber. Don't worry, we'll look into this so that you can get back to playing in no time! We do appreciate you a ton for providing the troubleshooting steps you've tried already. We totally agree with manually deleting all the contents of Beat Saber!


Can you please try the steps below to check if it helps:


  • Sign out and in of the mobile app.
  • Then try to update it again.
  • Uninstall and reinstall the Beat Saber app.
  • Uninstall and reinstall the Oculus mobile app.


We look forward to your response, please keep us updated!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!