Showing results for 
Search instead for 
Did you mean: 

Bluetooth Mouse paired but not working.

Level 3

Hi All,


I just purchased a Logitech MX Master 3 after following what some other people out there have successfully used with their Quest 2.


I can pair the bluetooth mouse OK, however it doesn't do anything, no cursor, nothing.


I have also tried pairing a Microsoft bluetooth precision mouse and had the same problem.


I have paired a K830 keyboard/trackpad combo before and have been able to use the trackpad fine in the Quest browser, but it is quite clunky to use effectively.


I have tried removing all other paired bluetooth devices from the Quest and have only the mouse paired, but still no luck.


I also noticed that when looking at the keyboard settings in the bluetooth pairing menu that there is a toggle switch for "input device". There is no such toggle option in the Mouse settings.


Lastly, I also tried factory resetting the Quest 2, but still no luck.


Anyone else had this issue?


Level 2

I have had the same issue with the MX Master 2s. After the headset restarted the mouse doesn't connect to the headset anymore and needs to be repaired as well as not doing anything when paired like the main post

Level 2


- remove all BT devices

- reset experimental features

- retry pairing



Clear cache and data on oculus app on your mobile device


Level 3

I'm currently having a similar issue with my MX vertical ( )
Did you manage to make it work?

Level 3

Nope. I haven't tried since January. What I ended up doing is geting a USB-C dock that had power pass through and plugging the USB receiver into that. Works almost perfectly, only problem is the scroll wheel scrolling really slowly.


Level 3

Thank you, I bought a usb a 3.0 to usb c adapter it works very well 🙂

Level 3

I am having the same problem with my bluetooth mouse.  It pairs but doesn't function anywhere in the Meta Quest 2 environment, not even in the browsers.  I try  different bluetooth mouse, one Logitech, one from Technet. Both can pair successfully but neither functions anywhere.


Is there a fix for this yet?  Or do I have to revert to using a usb c dock with power pass-through suggested above?  If a usb-C dock with power pass-through is the only way, what is that device, can someone show me an example?  Thanks

Hey @YouCanCallMeTJ, we know how worrisome it can be for your mouse to not function properly. Have you attempted to power-cycle your headset as well as a factory reset? If you're giving that a try, please make sure you have Cloud Backup enabled so you won't lose all your data.


We're very limited on troubleshooting these issues on this platform, we recommend Submitting a Ticket and we'll be able to assist further on that platform!

Level 3

Appreciate you responding Support team, yes I have powered the headset off and on.  But there is no way I am doing a factory reset just to make a mouse work and when everything else works perfectly fine.  Factory reset should always be a last ever resort when troubleshooting.


I might submit a ticket but I will troubleshoot other ways first. Thanks


To the rest of the community, if you do use bluetooth mouse (natively, not on a PC), successfully, can you let me know what mouse you use?  Perhaps some BT mouse are just not compatible even if they pair successfully.



Sounds like a plan, @YouCanCallMeTJ! We can definitely understand your reluctance to factory reset the device for this issue, since we're limited on our available troubleshooting for this particular issue, it's the best bet as far as what we have available. Reaching out to Meta Store Support if other troubleshooting you try out doesn't work would be a good idea, they'll do everything they can to help out with this!