Showing results for 
Search instead for 
Did you mean: 

CV1 dropping frames but Quest 2 with link is not.

Level 5

this has drove me mad, back and forth with nvidia with driver logs but no.... its oculus software.

specs are 12700k, 3080ti, 32GB ddr4 3200mhz

cv1 is dropping frames with random spike dips in the gpu headroom in any game, I'm using beatsaber as an example as I can notice them with absolutely no monitoring software or hud to rule out that being issues with nvidia card, these are frequently a few seconds apart or less and either a dip to 89fps or down to as low as 86fps. gpu headroom is obviously high, up in the 70% range, happens even with 1 sensor and headset on the same powered usb hub and port I use for link cable.

the same scenario when I use my quest 2 with wired link, even with 1.7 link resolution, 90hz, 3664 encode, 500mb bitrate, does not show the frame drops, either with or without the mobile asw feature enabled.

I've spent a whole day troubleshooting and only now (just past midnight) seen that link is fine, I've changed various windows and bios settings, reseating and testing ram speeds, cpu speeds, cores, gpu speeds and voltage locks, tried every port on mobo and pci card with and without powered hub, every combo of sensor and headset, everything including sending logs to nvidia driver reports.

both v39 and v40 ptc are showing this issue.

I'm not sure what's happening as there is no change apart from the oculus version since I've last played, the cv1 is still getting 18ms MTP, the quest 2 is still getting 37ms MTP, I can only presume something in oculus drivers has been messed up by a recent update, but then locking my card to low frequencies and setting a limiter didn't solve anything, my CV1 is my main PC headset and dropped frames especially in beat saber are very noticeable, but its present everywhere not just limited to oculus games but also steam VR which is why I originally suspected the gpu drivers (which i've tried all the way back to the cards release)


Accepted Solutions

Level 5

FIXED, wow this was a long winded process of elimination and it's very odd how link isn't affected, but here goes:

the TLDR to fix is, open task manager, click on the details tab OVRServer_x64.exe, right click and set priority to HIGH, and do the same for the game you are playing, doing either one alone will not work it has to be both.

you can do this with game running and issue presents itself as soon as you set either one to normal again, note that closing your game will end the process and you will need to set priority again, same for when you close or restart oculus server or PC, there are programs that can help you do this automatically but I wont go into that.

WHY this is happening for CV1 and not LINK I seriously do not know, but at least its an easy fix and one oculus could push in an update if they remember, just took me 3 days of doing absolutely everything else to find.

View solution in original post


Community Manager
Community Manager

Hey there! If you could please head on over to our support site and submit a support ticket with your logs attached, we will leave the steps on how to collect logs down below. When submitting a support ticket, please make sure to include all details regarding your issue. Thanks! We look forward to hearing from you. 


  1. Open the Run window (Windows key + R).
  2. Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
    • The above link is the default directory. Bear in mind that if you installed the Oculus PC app to another drive you will need to update the command with the correct file path.
  3. Select the checkbox next to ‘Full logs’.
  4. Select "1 day" from the "Collect last" drop down list.
  5. Wait for the log collection to finish. This can take some time to complete.
  6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
  7. Attach the newly created zip file to your next support response.

Level 15

@Mazda_Ron  With your 12th gen Intel cpu you are probably using win11 in order to get the best out of it.  So, no big surprise imho.  Hopefully both Oculus and Steam will officially support win11 soon.  Up to you to decide whether or not to roll back to win10 in the meantime.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro

I've dual boot of windows 10 which is specifically for VR games only which is where im having the issues, I've never put vr on windows 11.


Also means there is nothing interfering as it's pretty bare bones with regards to any other programs on the os, nothing but what's required to game in VR, even used nvcleanstall to get rid of all Nvidia hidden stuff I don't need.


Windows 10 also has the scheduler for the 12th gens, no issues with performance on CPU and until recently no issues with anything at all, was always silky smooth 18ms mtp with no frame drops 

@Mazda_Ron  okay I guess you just need to see if oculus support can identify something in your log files.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro

First thing I did 😁

Ticket 4879861


There was no options for software issues under cv1 so I've chose closest relevance I could and explained in the ticket.


Level 4

I have a similar problem with the Rift-S.


In all Unreal Engine VR games I have stutters, framedrops and microstutters (I have tested about 10 UE4VR games now).  Unity games seem to work and I cannot reproduce it in games that use other engines.  However, I don't have Beat Saber specifically to test it on.


It's like there's a severe sync issue and the moment the engine has to do something I get application frame drops.  Some UE4 games are worse than others, but I know they used to run well even on weaker hardware a year or so ago.  Even with a lot of headroom and good CPU/GPU frame times I get the dropped frames and the fps will fluctuate between 77 and 80. That's when it's most stable.  When the engine does any more work the drops and stutters get worse, and at times I can just be still and the graph will micro-stutter (rapid bouncing).  Also, if I force 40fps on the HMD it will still drop frames and go between 37 and 40 fps.  App Ahead Time races up when it happens, and much of the time the headroom graph only drops a little when it happens, not enough to justify an application frame drop.  The stutters and spikes seems like a bug, but I have no latency issues, even when stress benching both GPU and CPU.  LatencyMon says my PC is good for audio in green. 


I've been through Oculus support and they replaced the HMD, but the problem remains.  I can now duplicate it on two computers (Intel and Ryzen) and two graphics cards (gtx 1080 and rtx 3080 12gb).  It also happened on a 3080Ti, but I returned that as it was a waste of money and would crash the previous HMD.


Oculus obviously didn't find a problem in my log files, so now I am at a loss as to the problem.  Both machines run Windows 10 21H2.  They both use one of the recent Nvidia drivers, but I did test the 1080 with an older driver (a 466.* I think).


The only thing I can't rule out is Oculus software (both PCs were/are running the latest version).  It's very hard to figure out, because it's UE4 specific, and like I said, they worked a year or so ago ( I didn't do much VR in 2021).

My issue seems to be anything, not specifically engine related, im using beat saber which is unity to troubleshoot and log as I can time it and see if and feel any improvements, when using oculus debug tool- tools- performance profiler and recording a play through of a song along with the lost frame capture tool also in debug tools, that takes screenshots and tells me what frame (s) were dropped but nothing is out the ordinary, its not any fixed point in the game and no two play throughs are plotting the same, so its not a specific area or part of the level, just seems to be apprenderqueahead, doesn't really matter if I try force nvidia to pre render 4 frames instead of the default 1, I can only presume link isn't showing the issue as its given more time by default to do the compression, if I load up the GPU with 3.2x supersampling on headset, it does produce less drops but not enough to fix the issue, I can only get the latency to 27mtp max even stressing it, which is still faster than link gets

My best absolute guess is maybe the feature for mobile ASW that has been implented for use with link has changed some sort of frame prep times for the runtime, the compostior will very rarely be a cause of a framedrop for me, its showing in logs as the app frame drops even with a pretty consistent gpu overhead before it happens,  on recent log it sort of shown between 300-500 frame apart every time it would drop one or more frames, then was fine for 2800ish frames, then drops 3 frames before going back into a pattern of 300-500 frames apart dropping anywhere from 1-5 frames.

impossible to replicate a cause, really doesn't matter what situation I seem to put it in and just can't really understand how its possible to have more compute load with link at higher res and encoding ontop and not have the issue.

disabled all processes that made windows barely work and that made no difference, disabled e cores and several more intel cstates and boost features, just really does seem like its the oculus runtime not working fast enough anymore.

Level 4

Perhaps the issue is affecting us a little differently because they're CV1 and Rift S.  However, you say your Quest 2 works perfectly?  If so then the common denominator is the Display Port/HDMI (direct), and if Oculus has discontinued all hardware that uses this method then maybe the lower priority introduced a few gremlins.  Since getting a more powerful card I disable ASW, because under normal circumstances my system is overpowered for the Rift S. Also, the compositor never drops a frame and using performance analyzer I can see that the compositor is very stable. 


It isn't a PC problem, so I can't fix it.  The issue is consistent across all Nvidia drivers of late, so hard to blame them.  The OS was clean installed and I have no RGB or monitoring software, and only use Oculus Debug Tool for monitoring the problem.


Like you I have been in and out of bios and have checked all hardware.  I tried disabling c-states but this wasn't the issue.   I tried it on a different PC, which I had when I first got my Rift-S and the problem is now identical on that today.


Still, I am glad you don't have this problem with the Quest 2.  Hopefully I can play my games again someday.

Does sound strange, also if the OP already is using Win10. 


I'm using the CV1 with Win10 Pro and have no issues, and 3080 Ti should be very similar to a RTX 3090 - CV1 works smooth as silk on my rig. Might be some random issue...

Valve Index & Oculus Rift CV1, Asus Strix OC RTX™ 3090, i9-10900K (5.3Ghz), 32GB 3200MHz, 8TB
"Ask not what VR can do for you, but what you can do for VR"