Showing results for 
Search instead for 
Did you mean: 

Can't find "Phone Notification" option to enable Android notifications in V34 update


I have upgraded to V34 and wanted to try out the Android phone notifications on my Quest. You're supposed to initiate the feature by going to the mobile app, under "devices" and enable the "Phone Notifications" option there. My mobile app does not have "phone notifications" under "devices"... just:



developer mode



... am I looking in the right place? I believe I'm on the most recent app version - there no update option in the play store. Any ideas? Maybe the feature isnt available yet for my Galaxy S21?

280 REPLIES 280

This resolved my issue!


I found an actual solution to the problem that works for me. Here is the solution:


1. Uninstall the oculus app.

2. Install the oculus app again.

3. Log in with your facebook account to the oculus app.

4. Don't go to headset settings yet, and close the app and go to app info.

5. Force stop the app.

6. Enable all permissions for the app. Including the one to install unknown apps.

7. Start the app and you should now see the phone notifications option under headset settings.


If this still doesn't work, try clearing your app data, and app cache, and do all the steps again. If that doesn't work, go to settings, apps, find: special access, click: notification access, find: Oculus, and click the slider to enable it.


Let me know if this helped!

Community Manager
Community Manager

Hi everyone! We know it was a bumpy launch, but as of now, Android Phone Notifications for Quest 2 should be available for all users. The team has notified me that as of now the update/fix should have rolled out for everyone. Make sure you've got v137 on your mobile app, and you should be all set.

For anyone still having trouble, I'd recommend starting with the steps suggested in here already, uninstalling and re-installing your app. If that doesn't do the trick, you could try the steps @XdgamerleololVR just posted.

If you're still having trouble seeing the setting, or anything else, please report a bug and it would be good to contact the support team directly to investigate further. Though the team fixed the main issue, that doesn't mean other ones that haven't been detected aren't playing up. Bug reports and troubleshooting will help the team find them.


Thanks everyone for your patience and support while we got this sorted out.

Help others find great discussions and answers by adding kudos and marking solutions to your questions.


Okay, the fix was not applied on its own. So you just need to go to Settings - Apps - Oculus - Memory and hit Clear Data (no app re-installing is needed if it is already Then you start Oculus app and it will guide you through logging in to enabling Notification Access (if it wasn't) and finally you can enable Phone Notifications. Mission accomplished.

Honored Guest

pixel 5a here, cannot get it to work. Have had v34 and 137 of app for a while now. After trying storage -> delete cache, delete storage and running the app again, I see the 'phone notifications' selection, and when I select it it brings me to a permissions screen where I can select which apps can process notifications, and I select the oculus icon, and move the slide to 'allow notifications'.


But at that point, it stays on that screen, I can't do anything other than press the 'back' icon, and when I eventually get back to the 'devices' tab, and select notifications again from the devices tab, it brings me to a screen with a slider within the app regarding enable notifications, but moving the slider to the right flashes a graphic of the headset and immediately jumps back to the screen with just the slider.


I checked to see if notifications were working even though the app seemed to be in this odd state, but notifications still aren't working.


I repeated the process described above 3 or 4 times now, it always goes through the sequence I described.

@borisivan wrote:

it brings me to a screen with a slider within the app regarding enable notifications, but moving the slider to the right flashes a graphic of the headset and immediately jumps back to the screen with just the slider

Actually on the screen with a graphic of the headset (which appears after toggling the slider in the app) you need to press Continue and Enable buttons. Does the slider stay in the enabled state (blue) after all? You may also check Notifications state in Quest - it also should become enabled. 

Yes, I forgot about that... Could be smart to try that as well...

Not applicable

So disappointing. After all that, the feature still doesn't work. I tried everything. I do get the Phone Notifications option, but when I try to turn it on it blinks to another screen and blinks right back again with the switch off. When I uninstall and reinstall the Oculus app and to try again it asks me to "pair with null", whatever that's about, which doesn't work. I reported a bug. Not sure what else to do at this point. Sigh, I really wanted this feature.


Honored Guest

I'm in the same boat. All is set up and connected. But no signs of being notified in vr. Motorola 5g one Ace. All up to date. Sent bug report as well. Hope it gets resolved would love this feature. 


I followed the delete data and that got me the option to Enable Phone Notifications in the phone app. I have the permission set for notifications from Oculus. The HMD shows enabled and always calls and messages. No other apps show up. I still don't get any text message notifications. I am using the google SMS messages app, could that be the problem? I don't use the stock Galaxy messages app (Galaxy S8+).

EDIT It also shows as connected to my phone in bluetooth pairing