Showing results for 
Search instead for 
Did you mean: 

Can’t get Steam VR to work at all w/ Airlink


Having numerous frustrating issues with Quest 2 and Airlink working with Steam VR. First it took forever for me to even get the headset to work with Airlink at all but I finally got that issue resolved after finding the right Airlink setting toggle and resetting it. 
Maybe I just don’t understand the proper sequence for getting a Steam VR game to work but I make sure my Oculus app is running on the computer. I then go into the headset and go to the Airlink and launch it. From there I can see Steam VR app. If I click it, it often does nothing, but sometimes it will go into an open space home view where I can see mountains in the background and stars above. But there’s nothing there. Nothing to click on. 
I saw one article that said you had to add the Steam VR game you want to play into the library of the Oculus windows app. So I tried that. I selected Phasmophobia and added to my library. I then tried launching the Airlink again from the headset. This time I can see Phasmophobia as a game selection. I try launching it but the splash screen comes up and just says “Loading…” forever and never does anything…however the game launches on the computer and I can hear audio from the game coming from the Quest speakers. But I’m stuck on the loading screen inside the headset. 
I’ve also noticed I get some kind of warning on the oculus app telling Oculus is not set as the current default OpenXR runtime. It gives me an option to set it, but the link and button in the app don’t do anything. Nothing changes.  It currently says SteamVR is my current runtime. I’m not sure if this is causing my issues or not?

This is so incredibly frustrating and it’s not an easy, intuitive experience at all. 


I normally load up Airlink, open the PC desktop from within the headset and just run my Steam VR games from there. As an alternative, press the left controller menu button when in the Steam VR mountain / aurora void to access Steam itself.

The OpenXR thing would only affect OpenXR games, and even then shouldn't be catastrophic. Changing the setting requires administrative rights so if you want the Oculus app to do it, right-click the shortcut and select "Run as administrator"

So two things. Once I launch Airlink, I have the option to go into “desktop”. One video I saw said you need to launch steam vr from the desktop option once you’re in Airlink. His video showed him being able to use the quest controllers to select things in his windows desktop. I can’t do this. My controllers won’t click on anything in my mirrored desktop that displays. I can resize it and move it around, but it’s just a mirror image of what’s on the computer. I have no idea how you’re supposed to get the oculus controllers to be able to interact with the mirrored desktop. 

second, I’ve tried pressing the menu button on the left controller when in the steam vr environment. It just takes me back to this loading screen. It won’t bring up any menus to where I can select a game. Nothing any of the YouTube videos I’ve watched work for me. Something is seriously broken.  


You need to opt into the beta build of steam vr for the best experience.

I can certainly try that. Still doesn’t explain though why I’ve seen vids of people being able to interact with their mirrored desktop using the quest controllers but I can’t. I can only move the desktop around and resize it but I can’t interact or open apps within the windows environment from my quest. 

I thought an issue might be that my son’s windows account doesn’t have Admin rights. So I right clicked the Quest app and selected “run as admin”. That didn’t do anything either. So then I logged into my windows sign-in and tried to launch the Quest app. It made me sign in so I used my son’s sign in info. But then it threw an error about setting the folder for downloads. So I can’t even use the app from my windows sign-in, and I’m an Admin!  


So I think I got this thing fixed. I basically had to make my son’s Windows account an Admin. I hate doing that. I really don’t want to do that. But that was the only way I could get the Quest Airlink Remote Desktop to where I could click on things with the controllers. This allowed me to launch Steam from the Remote Desktop. I click then select his Phasmophobia game and click Launch In Steam VR and it would launch the game. But Steam VR is still not acting the way all the YouTube videos I’ve watched say it should. If I just purely launch Steam VR, it will take me to this mountainous space world. But there’s nothing there. If I click the left controller menu button as stated on one YouTube video, it just takes me to the SteamVR splash screen. But there’s no list of Steam Games or anything as the one YouTube video I watched said there would be. I’m still really confused and frustrated.

Do you know why I might lag so bad my occulus is a whole 2mins behind.

Hey there, @WrightOcculus! We noticed that you are experiencing some lagging while using Air Link. We totally understand how immersion breaking that can be and we'd love to help you get this issue resolved as quickly as possible! Listed below are the best practices to utilize when using Air Link:


  • Have your PC connected to Router/Access Point via Ethernet cable
  • Headset should be connected to Wi-Fi via 5GHz band (AC or AX)
  • Router in the same room as the headset or in line-of-sight, and at least 1m (3.3ft) off the ground
  • Non-mesh network configuration

If you believe that you are doing all of the above mentioned suggestions and still experiencing issues, we'd recommend reaching our to our dedicated Support Team by clicking here so that we may further assist you. Please let us know if you happen to have any further questions or concerns. We are always happy to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!