Showing results for 
Search instead for 
Did you mean: 

Can't install Software - Exiting with code 18


A few days ago everything worked fine and i was able to play with my Oculus Rift.
But today i had to reinstall the software and now i can't install it anymore.

I already turned of any software like antivir and my firewall and windows defender aswell.
Also i reinstalled my windows.

[Debug] [11.11.2018 16:41:44] Installing oculus-runtime.
[Error] [11.11.2018 16:41:46] Librarian exited code 18
[Debug] [11.11.2018 16:41:46] Install 'Dawn.Setup.InstallPackagesStep' failed.
[Warning] [11.11.2018 16:41:46] Rolling back installation.
[Debug] [11.11.2018 16:41:46] Uninstall 'Dawn.Setup.InstallPackagesStep' succeeded.

I hope this section from the log helps.
108 REPLIES 108

Not applicable
i have exactly the same problem with the same OculusSetup log, it worked for a little over a year without problems. I already tried to format my drives and reinstalled win10 twice, turned off Defender and firewalls, tried different installers, fiddled with permission settings. I just dont know anymore. Does anyone have the same issue or better a solution?

Same issue here. Everything was working until the new update, which was, incidentally, FORCED on me.

Honored Guest
i have exactly the same problem... i haven't solutions...

Has anyone in this thread opened a support ticket yet?

I did today

Honored Guest
Having the exact same problem and have messaged support but everything theyve sent so far hasnt worked. IE disabling windows defender and restarting in safemode.

I've already tried everything I could find on the internet but none of that seems to work for me... I really have no idea what else to try

Grand Champion
Make sure your game library folder is something like E:/RiftApps and NOT inside C:/Program Files or any other Windows protected folder.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

Nope... installation failed 
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?