Showing results for 
Search instead for 
Did you mean: 

Can’t login to account on headset

Level 2

I have had my quest 2 for a bit more that a year, and have never heard of this problem. On my iPad, it tells me I’m logged in, but on my headset, I’m not logged in, and it’s been like this for about three weeks.


Community Manager
Community Manager

Hey there, we definitely want you to be able to get into your account and get back in the game. We're here to help! Sometimes this kind of issue can be fixed by following these steps:

  • Switch your headset off.
  • Log out of your Facebook account on your mobile device, and then log back in.
  • Log out the Meta Quest application on your mobile device, and then log back in.
  • Start your headset.
  • Check that your headset is paired, and give it a few minutes to sync back up.

That should get everything showing up right in your headset. Let us know if that works to get you back in, or if you need any further assistance!

Community Manager
Community Manager

Hi again! We just wanted to check back in with you to see if you were able to try the troubleshooting steps we suggested. Let us know if it worked, or if you need some more help. We're here for you!

I’ve tried multiple times, doing different steps every time and I can’t seem to login to my headset. 

Never mind, got it! 

Level 3

I've got same problem and been told its since new update and there working on it app says connected but device is stuck on pairing page 

Hey guys! Well this is certainly a predicament! A predicament we can all get out of! *airhorn noises*. Let's have y'all mosey on down to our most awesome support channel where we can use out wide array of support tools to their maximum capabilities and get y'all back in tip top condition! You can reach that awesome support team here:

We'll get you going ASAP!

i cant log into twitch