Showing results for 
Search instead for 
Did you mean: 

Cannot checkout in Meta Store.

Level 2

Hello, for two days now I have been trying to buy Oculus Quest 2. Unfortunately I cannot proceed through checkout. Website tells me that my address is invalid and checkout button is disabled.


None of the fields passed with negative validation, looks like whole address form validated as FALSE with error NULL (checked it through web browser console).


What I tried:

- get rid off polish letters,

- change address,

- change zip code - this worked for me only for a brief moment and it was random zip code in my country

I also contacted support which is very hesitant to respond to my emails on any update/eta or anything that would be of help to me. Btw the only zip code format that works is XX-XXX.


The only tips they had was to:

- change network - didn't help

- clear cache and cookies - didn't help

- change device - didn't help


I really don't know what to do now. Buying from 3rd party retailer is not something I can do for several reasons.


I've been waiting to buy VR headset for years and now when I have a chance, I am not allowed to just because of some not working backend validation.