cancel
Showing results for 
Search instead for 
Did you mean: 

Casting to browser: Missing Options & Distorted Audio

Ecleos
Honored Guest
Yesterday, streaming to the Google Chrome web browser is blocked in widescreen mode, with no possibility of switching to 4:3 mode as before today. What's more, the audio quality is suddenly very poor.
 
I reset my quest 3 and all options were present and back. No more sound problems. I turned off the headset which told me that it would perform an update before extienction and now, I have again the same result (no more choice between 4:3 and 16:9, no more microphone option and a very bad sound quality). This bug is only present on cast to browser, I don't have any problem on chromecast (sound offset but this bug has been present for years now and known on the meta side).
 
option after reset :
Ecleos_0-1714209493782.png

option after shutdown and update :

Ecleos_1-1714209557955.png

 

For an overview of the sound quality, see the video of itsthedon, which also has the same bug:

https://youtube.com/live/9ddGECEfIak?feature=share 

 Ecleos_0-1714211542878.png

 

Is anyone else experiencing this problem? Could you remedy it, and if so, how?
137 REPLIES 137

After factory reset it works for a sec, then it updates and breaks again. 

David_Runs
Honored Guest

Since updating to v64 a few days ago, and even after updating to v65 today, when I try to cast to PC the audio sounds garbled. It used to sound good before the update. It still sounds good if I cast to the app on android but not when I cast to PC. I've tried multiple browsers, even on another PC and got the same result. I need to cast to PC to stream to YouTube using OBS and livesplit for recording speedruns. Please help me!

but then if you update the headset wont the issue return? 

The sound is horrendously bad when using "cast to browser" for me, but not when using MQDH or mobile app.

Version: 64.0.0.504.368.586682908

Browser: Brave / Chrome

Source Device: Quest 3

Computer: MacBook Pro 14 - Sonoma 14.4.1

HogButcher
Honored Guest

IMG_20240507_123128.jpg

Hello, I have a problem with streaming. When I go to Oculus Casting with the Quest 3 and start streaming, the sound is very very quiet and stutters. my microphone so you can't hear me. I have reinstalled PC Windows since then the layout has also changed on Oculus Casting. I previously had 2 controls for microphone and game sound. Now I only have one slider and the sound stutters and is very quiet. I tried a laptop where it worked before. I have not reinstalled Windows on the laptop but same problem. Mobile app Oculus also sound very quiet and stutters. So you don't want to listen to the sound. Then I tried to tap the stream with cable and the Developer Hut tool same problem. Internet is at 50mbit and it comes through.  Support says he doesn't know what to do, I should ask in the forum. Sorry about my English is a translator. Answer in German very welcome. In English too. 🙂

Any game I play on oculus.com/casting trying to share through obs streaming on twitch will have a loud distorted sound.  win 11 - i7 12700k geforce 3060 48gb ram 4200.  

any game i cast just the browser itself as we not even at obs yet. so obs isnt the issue just going into the browser the sound is messed up. I muted the mic in settings as the sound icon is just one icon to mute now instead of two . use to be one for mic one for sound . so I muted the mic in the settings otherwise I just hear echos of myself.

here is a video of it. it is unlisted so have to use this link to access it. 
https://youtu.be/74MO7QSaFGM
this is on any game i load.  but only through the oculus.com/casting with the browser. 
I went through so many changes on things I am running out of ideas. 

What should I do? I did not have this issue a few weeks ago.  only started a week or two ago not sure exact date . 



Ecleos
Honored Guest

Hello,

The problem comes from an update performed when the headset was turned off. There is no fix for the moment on the meta side. The meta support advises to reset the headset and block updates. I wouldn't do that, preferring to wait for a fix. As a workaround, I use the AirReceiver AirPlay Cast DLNA application (€2 on the Windows store). The result is equivalent or even better than the meta web cast.

Yep - my headset was fully reset and then updated after and then again yesterday - issue persists - previous mic/setting buttons are missing and bad audio...

Thanks for sharing - any idea what option you would have for mac users as my PC is restricted permissions as its a work laptop so i cant install anything on this machine..

Scribblecloud
Explorer

exact same issue for my friend, what the hell man?

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?