Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge




I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

What's blowing my mind is that I just checked my laptop (I haven't played VR/opened up the Oculus app on it in like 3 months), and there it works fine? The login screen also looks different, and it lets me through. How is this even possible lmao

Honored Guest

My oculus app won't connect to my headset because of this new stuff meta is doing I can't fix help

I have the exact same issue. Just updated to a Meta account and I cannot log in to my Oculus app, giving met the exact same message.




Went to the Meta website (all the "get help" links are broken links - wonderful work), downloaded the latest version of the Oculus App (the installer is version and it detected that the Oculus App was already installed. I pressed "repair" and it continued to install the app.


The result was the same: cannot login because the app is not supported.


Please help. The customer experience is extremely poor at the moment. Is this what Meta is?

I have the same issue. I went to the Meta website, into the Horizon part (don't even know what the hell that is) and I downloaded the Oculus installer app there (verison Re-installed the Oculus app but with the same result.


The upgrade path that Meta has been working on for months is apparently untested and broken. 

I wish I had waited.

Exact same issue here. I'm currently waiting for the fix.

Honored Guest

i cant sign in or use oculus app on desktop pc


the error i get is:

your using a version of this app that's no longer supported download the latest version to continue


i already have the latest version, i reinstalled via a repair but still this error. i just recently merged with meta or horizon and facebook, this problem didn't occur till i merged


what do i do to get back to using the app?

Honored Guest

Hi, earlier today I got this error message. 
I downloaded new app, installed, but still can't log in, either using FB or Oculus account. Saw few other people getting this error, but still no fix for it.



Me to, and many other on reddit.

Congrats to devs 😕

Seem they didn't rolled an update yet. Wonder how we will update the app, if we can't open it



Got the same problem here would've expected them to implement a fail safe or something