Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge




I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

I'm lucky!
I've tried everything. Language changed many times.
But I also deleted my rift S once in device manager.

Search for new hardware.

Installed again (takes a few seconds)

Changed language from english (US) to Nederlands ( My language)

EDIT: I unplugged my Rift S (both cables and put them back again also.

And in one I got this login screen.

The link that opens starts with:

And a lot of information after "="

Maybe someone can do something with that.
Maybe I was lucky, maybe it works for more people. 

2022-08-24 22_39_32-Oculus.png

I stay login now, sorry 😄 

This is what it said this the version of this app that's no longer supported Download the latest version to continue"

I think I may have hit on something that has worked for me, and maybe it could for others? I closed down the Oculus app, then went into task manager and made sure that all Oculus processes were closed (there were three still working, look for the OVR ones) Then instead of doing a reinstall I did a repair (someone has already mentioned that option instead of remove and re-install) and low and behold I had the extra options for logging in. At first, it looked like it hung up on the login but there was no error and when I put the headset on, it was as I expected it to be. I'm just play testing it now to make sure, but fingers crossed...

Honored Guest

After i restart the oculus pc app a few times, the new login screen appears and i can now login.

While it may not be an issue for you anymore, this thread is being used for others still experiencing the same problem. If a new issue has appeared for you, you're more than welcome to make a new, separate post.

Have the same issue, have tried ending task, restarting, downloading oculus app and going through repair when installing, just keeps coming back to the same screen saying the software is no longer supported.


This worked for me, too. I went into Task Manager and shut down all Oculus processes. When I restarted the app, it gave me the new login option.

I have now restarted the Desktop app and I now see the new login, and I am now able to log in.

It worked. IDK what I did different from previous BUT it worked. Go figure.