Showing results for 
Search instead for 
Did you mean: 

Emerging Issue - Unable to log into Oculus App after Meta Account Merge




I am on Windows 10, I have an Oculus RiftS and the Oculus PC application.


I have just updated my Oculus account to a Meta account. 


When I log in to my Oculus app I get the message in the title: 

"You're using a version of this app that's no longer supported. Download the latest version to continue."


There's no download link and I don't know how to continue. I cannot use my Oculus Rift S at the moment.



383 REPLIES 383

Honored Guest

i had this issue as well. i didn't find any solutions online so i am posting this solution that worked for me. i launched steam vr through the steam app just to see if it would work, this launched the oculus app and it worked. idk if the devs just happened to fix it when i tried this or if this is a legit work around but my rift works just fine now

i have been having this issue with my rift. after not finding a solution i tried to load steam vr to see if i could still access my steam games. this force loaded oculus and it allowed me to login and works fine now

Honored Guest

Here is what I did. It might sound lame, but it worked for me!
Problem: I turned on the Oculus app, and it showed two options (1. Login with Facebook and 2. Login with Oculus) Even after logging in with Facebook it showed the following error:
Screenshot (8).png


After a series of uninstallation/repair/reinstallations, I couldn't solve the problem. Then I tried changing the language, and it showed the new Meta page, and I could log in again!!
Note: If I choose English(US) it shows the old page, but if I choose English(India) the new page is displayed.

Also, I had my Quest-2 connected via link cable, and I tried turning on Quest-Link before the fix.

Seems to have solved itself. Meta page appeared out of nowhere.

But my library is of course empty...So not really solved 😞

Yeah I practically have to redownload all. No big issue, most of the titles I play are on steam or standalone but still annoying. That's on me tho, I did not backup before "repairing"


This worked for me, and I didn’t need to do steps 2 or 9.

All the games seeem to exist in the headset but not 100% sure, have to reinstall them though. On me I guess.


The issue solved itself this morning. I logged into my Oculus App (still the same one as yesterday) and this time it presented me with a new option to log in using an email address. This button took me to the Meta website where I indicated that I was indeed me, and it opened the Oculus app as expected.


Problem solved. Issue closed, for me at least.

Eh deleted text... stupid thoughts 😄