cancel
Showing results for 
Search instead for 
Did you mean: 

Error SYSTEM THREAD EXCEPTION NOT HANDLED Win10 after the installation Oculus

kamskill
Level 2
Hello,
I installed Oculus Rift drivers downloaded from oculus.com/setup/. Everything is plugged in and installed properly.

The computer’s parameters:

Windows 10 Pro 64 bits
Intel Core i7-6700 CPU 4,00 GHz (8 CPUs)
32768MB RAM
GeForce GTX 1080

Oculus worked correctly, I tested demos, but the problem began at shutting down my computer. My PC couldn’t shut down on its own, I had to do it manually.

When I restarted the computer, the following error notification appeared: SYSTEM THREAD EXCEPTION NOT HANDLED

https://www.dropbox.com/s/25nij6g1pchslxb/20170204_003627.jpg?dl=0

restoring the system using a disk failed
trying to restore the backup failed
trying to enter safe mode failed
the backup from 3 days back was restored after typing rstrui command three times

The second attempt to install oculus rift

Correct installation and configuration, additionally with Steam VR installed
Movies and VR games tested – all worked properly.
I was trying to restart the computer, this time the device shut down without problems but right after starting up the same error notification appeared
https://www.dropbox.com/s/25nij6g1pchslxb/20170204_003627.jpg?dl=0

This time the system was fixed fast and the previous-day backup was restored.

What can be source of the error?
109 REPLIES 109

cybereality
Level 15
That error is usually related to old or corrupted graphics card drivers. I'd recommend completely uninstalling the Nvidia driver (maybe use something like DDU to be sure) and then reinstalling the latest drivers from Nvidia. Also, if your system restore is not working, that could indicate hard-drive issues. You may want to run a scan of the hard-drive to check for errors and/or repair them.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

kamskill
Level 2
Thank you for the fast reply. Disc scanning didn’t indicate any problems. When it comes to Nivida driver, recently I’ve installed Nivida Geforce Experience. So do I have to uninstall the drivers?
I made several attempts at my friend’s. One of them has played on oculus rift cv1 before and he didn’t have any problems with that. However, this time he had the same problem as mine. The second friend was testing oculus rift for the first time and he got the same problem when shutting down his computer. Both of them have Windows 10 and comparable computer’s specifications.

Might be the problem connected with one of the latest Win 10 updates?

cybereality
Level 15
Anything is possible, but I haven't heard many other people mention this error.
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

SpeculoosJoe
Level 2
Thank you Oculus! I ordered a third sensor including your USB cable from 2003? (It has only Win 98 / XP as supported systems on it....) and now it totally crashed my computer! Every time I put in the sensor I get a bluescreen "

SYSTEM THREAD EXCEPTION NOT HANDLED

Then I have to reset Windows (takes 20 minutes) and then the same happens again!

cybereality
Level 15
Might be a USB issue. Try updating your USB drivers to latest (usually found on your motherboard website). Otherwise, try buying this add-on card. 
https://www.amazon.com/Inateck-Superspeed-Ports-PCI-E-Expansion/dp/B00B6ZCNGM/
AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV

robertogeek
Level 4
Same error here, with 3 PCs with the same specifications:


Windows 10
32gb ram
i7-6700 cpu 3.4ghz
Nvidia Geforce GTX 1070

378.49 Drivers

There is any solution? I have the sensor and oculus rift unplugging and I can't run windows10 

jayhawk
Level 9
Can't remember exactly but I think this was the same BSOD loop I was in after reinstalling my OS. I restored to a previous point which allowed me back in (out of the loop).
What worked for me: Update all drivers including USB drivers. Install Oculus software BEFORE plugging anything Rift related in. 

mikeybox
Level 2
After the latest update I too am getting the exception and I can't boot in to safe mode either. So having to reset Windows 10 for the second time. Seems like a bug with the rift software because after a clean install with updated drivers it crashed as soon as I plugged it in. 

Ced
Level 2

This is really interesting as I see more having the same issue. Because I had already encountered this error in much the same way this post really caught my attention when it was first started by kamskill, so I finally decided to go ahead and speak up as well.

I too have dealt with this several times over already. After doing a complete reset/clean install of windows 10 the first time, and then a subsequent system restore or two, I haven't plugged my headset/sensors back in since. And found on my third or fourth BSOD exception error, if I restarted into the bios and disabled the USB 3 ports, I was then able to boot into windows normally without having to do a system restore again. The problem is for now I can't turn my 3.0 ports back on without getting the same exception error on startup, unless I would do another system restore. Which wouldn't be an issue really since I'm not far removed from the last restore of course.

But at this point I'm just a bit tired of messing with it all, and not entirely sure where to go from here anyway. At least I can use the computer/windows in every other way I normally would. So along with any other tracking fixes etc., just hoping there's something in the next update that may possibly resolve this problem as well, if that is indeed the cause. And allow me then to use my 3 sensor touch setup without issues, which would be so nice. Like I said though, it is quite interesting to be seeing more posts from people having this same problem since the last update.

My specs:

Windows 10
i5-3570K
ASRock Z77 Extreme4
8gb ram
980Ti