Showing results for 
Search instead for 
Did you mean: 

Glitching saga continues!


Still havent managed to fix the screen tearing / glitching on left eye...
Talked with support after submitting a ticket - which was like talking to a indian call center hahaha! 
They later just closed the ticket when their support manuscript ended.

PC setup: 
Asus Z690 Hero
Gskill ddr5
Win 10 / Win 11

Headset is the Q2
It´s stuck on v43 after entered public test channel - doesnt revert back to v42
Oculus software is v43 if in Public test channel and v42 if opted out.
I´ve tried fresh installs of drivers and even windows. Tried both Win 10 & win 11
Tried turning off power management on for the usb ports.
Tried both Oculus oem cable as well as the anker one
Tried several usb ports
I have a pci-e usb 3.1 card on the way to try with but I dont think that will help (Neither AsMedia pci-e usb card & Intel usb 3.1 motherboard controller makes any diff)
Tried factory reset the headset several times - it´s stuck on v43

Oculus console shows a numberous instances of xrstreaming errors - logs and pics was sent to 
Oculus support like they´ve asked for but they doesnt seem to know what it is... 
I also asked them to push out the v42 firmware but they said they couldnt.

My last resort is the forum - is there any VR developer in here with great knowledge? 
Please contact me! 



Community Manager
Community Manager

Hello there, @ChrizzyDizz. We are sad to hear that you are still having problems, but don't worry. 


We would be delighted to assist you in resolving this issue and getting you back to gaming. So that we can get this resolved, please PM us here


Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message.


We are excited to get you back in the game! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

PM sent..


Once again told to send a support ticket to their support division that allready have shown that their not able to get this sorted out. 

I want to get in contact with your firmware/software division - they´ve got the proper knowledge.Ocu.png