Showing results for 
Search instead for 
Did you mean: 

Graphics Card Not Supported? - NVIDIA GeForce RTX 3050 Ti Laptop GPU

Level 3

I keep getting an error message when opening the Oculus app stating my graphics card (NVIDIA GeForce RTX 3050 Ti Laptop GPU) is not compatible. However, the website ( states that "NVIDIA GeForce RTX 30-series (all)" is compatible. The four customer service agents I've spoken to haven't been able to fix my issue, stating that it keeps defaulting to my Windows basic graphics card or Intel(R) that isn't supported instead of using the NVIDIA one but that the NVIDIA one is supported. Any ideas of what I can do to fix it?


I've tried restarting everything, uninstalling my other (Intel) graphics card, disabling my other graphics card, setting the default in 3D settings to the NVIDIA graphics card, installing new drivers, making sure everything is up-to-date, etc. Any help is appreciated!


Community Manager
Community Manager

Hey megocakes, thanks for reaching out about this! Having your GPU not recognized is never a great thing to go through. Are you able to play disregarding the error message or is that preventing you from playing entirely? Sometimes the program may throw a false positive thinking the system isn't compatible.

Hi! It will not let me play; when I link my Oculus (via the link cable or Airplay as I've tried both), going to desktop view just displays a black screen, and I can't open any apps (I get an error message that says that I can't open any apps due to an active hardware issue).

Hey there megocakes, Below we've outlined some troubleshooting steps you could try to ease any potential link issues.



Are there any updates to Windows/GPU/USB?


Sometimes there may be an issue with the current driver that could interfere with the Link and its performance. You may want to try rolling back to another version to see if the issue persists. Also check for Windows updates, as that is very important too!


For Windows, there's an article on how to check for updates here!


If updates are found for either, make sure you restart your PC once they are complete, then try to use Link again.



Game Mode may conflict with some VR applications.


In Windows 10, there is a feature called "Game Mode". Game Mode appears to reduce or eliminate background processes and focuses performance on the active game. This could interfere with the Oculus software, as it needs multiple processes running simultaneously to function properly. Try disabling Game Mode, then attempt using Link again.


  • Open the Windows Settings menu
  • Click on Gaming
  • Click Game Mode
  • Toggle Game Mode off

Try another cable


Some cables lack the ability to transfer power or data. It's ideal to use the official link cable or a third party USB C cable, and not the charging cable that comes in the box, as this is designed for charging the device and not for link gameplay. While some users may report the charging cable working for link capability, we cannot offer any guarantees.


Submit a Support Ticket.


Collect Oculus Diagnostic Logs and submit them in a support ticket here so that we may look over them and confirm any conflicting software, PC/System updates and inconsistencies.



If you have any questions, we'd be happy to help! Cheers!

Hey! I've already checked for Windows updates, but I've gone ahead and turned off game mode. I am still receiving the same error, but I will try to open it up with the Oculus anyways and see if that fixed the black screen.


In regards to the link cable, it is an official Oculus link cable, and it works for my desktop and other laptops.


I have submitted a few tickets, and I've spent a few hours with a couple of agents, so I may try that again in the future, but I think I've hit a roadblock when it comes to that.