Showing results for 
Search instead for 
Did you mean: 

Help please! Air-Link Problem

Honored Guest

Hi folks! First post here. 


I tried using Air Link and ran into a problem , I've been searching web and forums for solution and can't seem to find one that works. I would want to see if anyone could help me 😞


I activate Air link , found my pc , connect them together with the codes everything works fine. When I click on air-link , it automaticly detect my PC , I click on launch then I see a white screen for 1-2 sec , then it flashes really quick for 3 secs and I end up seeing a messed up black / grey screen. All I can do from now on is close air link and open it back and it always does the same thing!


I have a beast PC so clearly not a performance problems.

Amd 5900x

32gb ram

6800XT GPU

1GPBS internet


No inboard graphics. 


I tried turning off windows game mode , graphics card update to latest, went to diag tool , the diagnotic oculus software with the default settings , rebooting pc , rebooting oculus , repairing oculus software etc.. Still that crash at the start 😞


Did anyone run into this and found a fix?