Showing results for 
Search instead for 
Did you mean: 

How to delete cloud synchronized video from oculus app ?

Honored Guest

How to delete cloud synchronized video from oculus app ?

I get two crap recorded video on the oculus android app and I can't remove them !

Videos do not exist anymore on my oculus 2 local storage.

There is no delete option !



Community Manager
Community Manager

Hi there, we're sorry to hear you are experiencing trouble with deleting cloud synchronized videos from your Oculus app. We recommend starting by performing a reinstall of the app.
If you require further assistance, you can receive live chat support by clicking here and choosing the chat button on the bottom right corner. We're here to help! 🙂

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I have the same problem on IOS. Delete your app and reinstall is not a good answer, it is always the go to answer.  If you are implementing syncing you should also give us the options how we want to sync, not sync or remove synced files from the app. Oculus should do better or give better answers than just that. Disappointed.

Honored Guest

You have to reupload the videos to your file transfer app, like android file transfer for pc, or mac I'm using. Then unsync the videos in the quest files app. If you delete them from the quest also there will be another error when you try to delete from the file transfer app. Just close it and they should be gone.

Same here. iOS and tried uninstalling app and reinstalling, same lame video sitting in “recent captured media”. Video isn’t on my quest 2. How do I get rid of it?

I have deleted and reinstalled the app and the video is still there. I cannot delete it. I can download it and edit it and delete that but cannot delete the original. 


It doesn't work anyway. I deleted and reinstalled and the offending video is still there. 

I tried to do what you said but cannot find the video on my Oculus anymore. it's just on the app and it won't let me delete. Am I missing something? Thanks.

Did you solve it? Same problem on two devices.  

Honored Guest

1.  They should self-delete in two weeks after deleting from headset.