Showing results for 
Search instead for 
Did you mean: 

I cannot open my files in MetaQuest2...

Honored Guest

File viewer worked perfectly, and than all of a sudden it disappeared. There is Files app, but it doesn't work good, 9 od 10 cases it doesn't show me any of my files. I have no option to watch the files i put on my headset (ones i record myself with Insta Pro2). I cannot download those apps again neither a 3rd party app. I made a factory reset, and it didn't help. I cannot find anybody reporting this problem online or any possible solution. And customer support where i bought it doesn't help either. What to do? Anyone knows what happened and how to fix it? 
Thanx a lot! 



Hi @davor.rostuhar  .

Once they are on your headset (are you dropping them in the Movies folder), when wearing the headset, are you trying to view them in Meta Quest TV/Your media?  

That's how I view my videos.  I did read somewhere there may be an issue when you go over a certain file size?

Honored Guest

Yes, I'm dropping them in the movies folder, and they are not particularly big, just short videos, so no issu with that. Afterall i played big 15 min files in File viewer previously. 
Thanx for this advice, i didn't know you can whach your stuff in Meta Quest TV, now i see i can watch them there, even though files are structured worse there. Prefer how it worked in Viewer and would like to figure out how to get that one back..


Glad you can now at least watch them.  Yes, agreed sorting isn't good in there (well, I couldn't work it out) - you can at least change the thumbnails though.