Showing results for 
Search instead for 
Did you mean: 

Known Issue - Cannot pair Replacement Quest Headset with the Oculus App


Hello all,


I recently got a brand new Oculus Quest via RMA, and I'm in the process of updating it. However, I'm having some issues trying to pair the new Headset with the app. I have the Oculus Quest 1 (or the OG quest).


When I try to setup the headset inside the Oculus app, I get through the part asking me to plug in the Quest to power, turn it on, etc. After I put in the pairing code found inside the Quest (sometimes it automatically finds the pairing code, sometimes it doesn't, don't know why), it says "pairing to headset". After a minute or two it spits out an error saying it cannot connect to the headset. I've tried all the following troubleshooting:


  • Factory Resetting the headset (even though it's brand new :/)
  • Uninstalling/Reinstalling the Oculus app
  • Trying the setup on multiple different devices
  • Turning bluetooth & location off and on again, along with checking the app has proper permissions to use them on each of the devices I tried it on
  • Restarting the headset & devices

I don't know what's causing this. Is anyone else having this issue, and if so, is there any potential fixes for it? I already opened a ticket with Oculus Support and all I got as a response is "our developers are aware of the issue are are currently working on it" which could mean a lot or absolutely nothing judging by how you look at it. It looks like a LOT of other people are having this issue, so hopefully they fix whatever's causing it soon.



~ Dom


(EDIT: I posted a fix in the replies which appears to have fixed the issue for most. If it helped you at all, and you'd be so inclined, feel free to use my referral code, as when you (finally) activate your headset, we'll both get $30 of credit to use on whatever you want:



Accepted Solutions

Meta Quest Support
Meta Quest Support

Hey hey! Just wanted to update this thread with this solution since it seems we may have forgot to post it in here.


For anyone having this issue, please try the following:


  1. Open the Meta Quest app on your iOS or Android device. Wait about a minute while a background update is automatically applied.
  2. Close the Meta Quest app.
  3. Factory reset your headset.
  4. Try to pair your controllers and headset as new.

Note: Please be sure to check your Mobile app and Headset for the latest versions.


If that doesn't work, we suggest hitting up the team with a support ticket


Thank you! 

Sometimes it's okay to be a little Bing Chilling

View solution in original post






Alright, so what I found is that by sideloading an older version of the Oculus Quest firmware to your headset, it will allow you to successfully pair to your headset. Keep in mind that I have the Oculus Quest-1, so newer models of headsets may or may not work with this method. Doesn't hurt to try!


Here are the steps I did to solve this:



Pre-Requisites: You need to install ADB (or "Android Debug Bridge") in order for this to work (you can watch the video I provided down below which also has steps on installing ADB if you need to). You'll also need a reliable USB-C Cable, and I mean reliable. You could potentially brick your headset if you use a flimsy/cheap USB-C cable, although unlikely it's just a mitigation step to saving yourself further headache later on.


- Firstly, you'll want to Download V41 from the R/OculusQuest subreddit. I won't post the files here (because I don't even know if that's allowed here, though if the Forum Moderators personally ask for me to, I guess I can.). Just do a little searching and you can find them pretty easily. Usually the "megathreads" are your safest bet, as they have the files stickied to the top of the comment section of them by the Mods. I personally used V31 which seemed to do the trick, though I'm not sure if there's a Quest-2 version for it, only found a Quest-1 version. Join their Discord and go into the Support Section of it if you can't seem to find it, one of the Mods in there seems to keep a backlog of them.


Next, you're going to need to Flash the file to your Headset. I won't reinvent the wheel, as "TheMysticle" has already done an amazing video on how to do exactly that. The only caveat is to use the Version File you got from Reddit instead of the ones he provides. You can find the video here:


Once you've started flashing the new firmware, you should see a percentage thing pop up. Once it finishes, your headset should automatically restart. Give it several minutes to do its thing after it says it's completed on the CMD Prompt. MAKE SURE NOT TO DISCONNECT THE HEADSET FROM YOUR COMPUTER WHILE IT'S FLASHING THE FIRMWARE, AS YOU COULD EASILY BRICK YOUR HEADSET THAT WAY!! 


Once you've finished flashing the firmware, you should now see a new "pairing screen" inside your Meta Quest. This is what you want. You should see in big numbers your 5 digit pairing code. Go ahead and open up the Oculus App, as you should be able to start the pairing process now. Once (or if) it pairs, it'll bring you through the rest of the setup process, and then it'll re-update itself back up to the firmware, so no need to worry about flashing the newest version over again!




And that's it! Hopefully this helps people, as it definitely helped me. Good luck to everyone here!

View solution in original post

204 REPLIES 204


I have the same issue after my right controller unpair when i was playing.....after try diferents alternatives cause my left controller continued working and my headsets to. When i done the factory reset to "try to fix" the problem, i have this one. They says that its a error and they trying to fix it

Honored Guest

I have exactly the same issue. The phone is seeing it (in parameters I see a Bluetooth device called Oculus Quest), but it is stuck exactly like yours.

I tried with android and iPhone oculus applications: exact same behavior.

I tried with an other Facebook account: it told me that this headset was ALREADY paired with an other account! (I suppose my own but with bad links, because this headset appears nowhere in my meta device list ).

Then stuck pairing with my account.

Oculus app says it is registered to an other account if I try an other account.



Honored Guest

I forgot to tell: it is also a brand new quest1 after RMA.

I have also a Quest2 working perfecly with my phones and the very same oculus application.

At first, my former quest1 was still appearing in my meta device list… I thought it could cause some conflict and removed it… but this didn’t change anything with the issue.

THEN it is NOT an issue with the device/phone/hardware… but certainly something is going wrong with META SERVERS when registering the Bluetooth identification of the headset with my account… it must be partially registered… enough to forbid the registration to other accounts, but not made well enough to finish the correct pairing process.

I am REALLY pissed…

Honored Guest

I my store would not open so I did a factory reset but it will refuse to connect to the oculas app and I am stuck

I may have found a spark of hope, although it's quickly fleeting. I'm in a Virtual Reality Discord server and in the support section a user noted that they installed an earlier version of the Oculus app due to their controllers not pairing anymore and it seems to have fixed his issue. (Off topic, but there's a LOT of people in there with a similar issue we're having asking for help, so it's obviously a bigger issue then we think.)


I'm currently trying to install earlier versions of the Oculus App via an APK. It seems to install okay, except that I just cannot log in with my account since it really doesn't like the fact that I'm using an outdated version. TBA if this works.


Hopefully someone else can chime in here and give some solution that could fix this. I also note, that while doing a Factory Reset, there's a "sideload version/update" option inside what I can only assume is what's basically the BIOS of the headset. Could there potentially be a way to forcefully install an update to the headset, one that's been verified to work?


I have a feeling this has something to do with Facebook pushing the new "Meta" accounts, ever since they released them the whole eco-system has been screwed. I could barely even log into the app today because of how buggy the log in process is. 


The fact that consumers have to do science experiments to get their headsets working shows how much oculus has failed us  

do you had any sucess with sideloading a older firmware? or do you have a link to the oculus discord you mentioned?


Well, I managed to get an older Oculus App APK that seemed to install okay, but the only issue is that I cannot sign into the app with my Oculus account, since it throws a fit that I'm using "an outdated version of the app". 


I talked to the person who I got the idea from to go back in version(s) on the app, and they said that signing into the app with a Facebook account instead of an Oculus account could potentially let me in. Only issue I'm worried about is that once I setup the headset, I would have to deal with linking my Meta Account and the Facebook account so I can get my games, also so that it doesn't become linked with an account I don't use/have anything on. There's also the good possibility that it won't work at all.


As for the Headset's firmware, I'm not really sure where to find previous Headset versions. I'm sure they exist, but I just want to be extra careful with the headset's firmware due to the high chance of it bricking itself and becoming a nice paperweight.


The Discord in question is the R/OculusQuest discord, (Disclamer: don't think it's managed by Oculus themselves btw) they have a little section inside said discord for support enquires. Though not sure you'll get much luck in there as it's all community driven, doesn't hurt to try though!

I see. I’m going to try what you suggested.
I too have a Red Lory btw.