Showing results for 
Search instead for 
Did you mean: 

Known Issue - Cannot pair Replacement Quest Headset with the Oculus App


Hello all,


I recently got a brand new Oculus Quest via RMA, and I'm in the process of updating it. However, I'm having some issues trying to pair the new Headset with the app. I have the Oculus Quest 1 (or the OG quest).


When I try to setup the headset inside the Oculus app, I get through the part asking me to plug in the Quest to power, turn it on, etc. After I put in the pairing code found inside the Quest (sometimes it automatically finds the pairing code, sometimes it doesn't, don't know why), it says "pairing to headset". After a minute or two it spits out an error saying it cannot connect to the headset. I've tried all the following troubleshooting:


  • Factory Resetting the headset (even though it's brand new :/)
  • Uninstalling/Reinstalling the Oculus app
  • Trying the setup on multiple different devices
  • Turning bluetooth & location off and on again, along with checking the app has proper permissions to use them on each of the devices I tried it on
  • Restarting the headset & devices

I don't know what's causing this. Is anyone else having this issue, and if so, is there any potential fixes for it? I already opened a ticket with Oculus Support and all I got as a response is "our developers are aware of the issue are are currently working on it" which could mean a lot or absolutely nothing judging by how you look at it. It looks like a LOT of other people are having this issue, so hopefully they fix whatever's causing it soon.



~ Dom


(EDIT: I posted a fix in the replies which appears to have fixed the issue for most. If it helped you at all, and you'd be so inclined, feel free to use my referral code, as when you (finally) activate your headset, we'll both get $30 of credit to use on whatever you want:


204 REPLIES 204






Alright, so what I found is that by sideloading an older version of the Oculus Quest firmware to your headset, it will allow you to successfully pair to your headset. Keep in mind that I have the Oculus Quest-1, so newer models of headsets may or may not work with this method. Doesn't hurt to try!


Here are the steps I did to solve this:



Pre-Requisites: You need to install ADB (or "Android Debug Bridge") in order for this to work (you can watch the video I provided down below which also has steps on installing ADB if you need to). You'll also need a reliable USB-C Cable, and I mean reliable. You could potentially brick your headset if you use a flimsy/cheap USB-C cable, although unlikely it's just a mitigation step to saving yourself further headache later on.


- Firstly, you'll want to Download V41 from the R/OculusQuest subreddit. I won't post the files here (because I don't even know if that's allowed here, though if the Forum Moderators personally ask for me to, I guess I can.). Just do a little searching and you can find them pretty easily. Usually the "megathreads" are your safest bet, as they have the files stickied to the top of the comment section of them by the Mods. I personally used V31 which seemed to do the trick, though I'm not sure if there's a Quest-2 version for it, only found a Quest-1 version. Join their Discord and go into the Support Section of it if you can't seem to find it, one of the Mods in there seems to keep a backlog of them.


Next, you're going to need to Flash the file to your Headset. I won't reinvent the wheel, as "TheMysticle" has already done an amazing video on how to do exactly that. The only caveat is to use the Version File you got from Reddit instead of the ones he provides. You can find the video here:


Once you've started flashing the new firmware, you should see a percentage thing pop up. Once it finishes, your headset should automatically restart. Give it several minutes to do its thing after it says it's completed on the CMD Prompt. MAKE SURE NOT TO DISCONNECT THE HEADSET FROM YOUR COMPUTER WHILE IT'S FLASHING THE FIRMWARE, AS YOU COULD EASILY BRICK YOUR HEADSET THAT WAY!! 


Once you've finished flashing the firmware, you should now see a new "pairing screen" inside your Meta Quest. This is what you want. You should see in big numbers your 5 digit pairing code. Go ahead and open up the Oculus App, as you should be able to start the pairing process now. Once (or if) it pairs, it'll bring you through the rest of the setup process, and then it'll re-update itself back up to the firmware, so no need to worry about flashing the newest version over again!




And that's it! Hopefully this helps people, as it definitely helped me. Good luck to everyone here!


Honored Guest

I have exactly the same problem as you, and have tried the solution. Unfortunately the adb cannot find my quest, so I cannot update the firmware. Any tip on how to get adb to detect my quest?


Did you do this on the Quest 1 or 2?


Hey it worked! after sideloading the update, it did go back to the controller pairing screen, but this time the five-digit code actually worked and I could proceed to connect the controllers to the device!

How did you get it to work? Do you have an oculus 2?

Not applicable

This sounds familiar! I’m in the same boat buddy so far lol 

Please share with us which Oculus do you have? 1 or 2 ? Thanks

So when’s the issue going to be fixed does meta even know what’s causing it