Showing results for 
Search instead for 
Did you mean: 

Known Issue - Cannot pair Replacement Quest Headset with the Oculus App


Hello all,


I recently got a brand new Oculus Quest via RMA, and I'm in the process of updating it. However, I'm having some issues trying to pair the new Headset with the app. I have the Oculus Quest 1 (or the OG quest).


When I try to setup the headset inside the Oculus app, I get through the part asking me to plug in the Quest to power, turn it on, etc. After I put in the pairing code found inside the Quest (sometimes it automatically finds the pairing code, sometimes it doesn't, don't know why), it says "pairing to headset". After a minute or two it spits out an error saying it cannot connect to the headset. I've tried all the following troubleshooting:


  • Factory Resetting the headset (even though it's brand new :/)
  • Uninstalling/Reinstalling the Oculus app
  • Trying the setup on multiple different devices
  • Turning bluetooth & location off and on again, along with checking the app has proper permissions to use them on each of the devices I tried it on
  • Restarting the headset & devices

I don't know what's causing this. Is anyone else having this issue, and if so, is there any potential fixes for it? I already opened a ticket with Oculus Support and all I got as a response is "our developers are aware of the issue are are currently working on it" which could mean a lot or absolutely nothing judging by how you look at it. It looks like a LOT of other people are having this issue, so hopefully they fix whatever's causing it soon.



~ Dom


(EDIT: I posted a fix in the replies which appears to have fixed the issue for most. If it helped you at all, and you'd be so inclined, feel free to use my referral code, as when you (finally) activate your headset, we'll both get $30 of credit to use on whatever you want:


204 REPLIES 204


Doing the sideload update detailed above resolved this issue for me. 


Support - please could you provide an update regarding this pairing problem and comment on the suggestions to side load new firmware.


The issue is still persisting

Hey, friend!


If you are still experiencing this issue, this may be an internal error caused by the PC system. Not to worry though! We'll get you all suited up and ready for the journey ahead! PC systems can be a bit heavy to look into. So let's start by gather some log files and then getting in touch with the awesome folks at our main support channel.


Here are the steps to gather your logs:


1.Open the Run window (Windows key + R).
2.Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
       *The above link is the default directory. Bear in mind that if you installed Oculus Home to another drive you will need to update the command with the correct file path.
3.Select the checkbox next to ‘Full logs’.
4.Select "1 day" from the "Collect last" drop down list.
5.Wait for the log collection to finish. This can take some time to complete.
6.The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
7.Attach the newly created zip file to your next support response.


Once you're all set with those logs, we'll move on over to those previously mentioned awesome folks here:


We'll see you on the other side, pistol!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, the issue is between my phone and headset, I don't see how any PC logs could be relevant. (Quest 2, iPhone 6s)

Perhaps they are looking for clues in logs as to what is going on / wrong with paring 

Not applicable

I always appreciate any help that's offered Dom but I have done it all and I'm just admitting defeat. Yep, I am, done, finished, No more, The end, Caput.....

Honored Guest

I'm having a similar issue, I just completed a chat with support about this.  I received a replacement headset today as my original quest 2 had a dead pixel. Out of the box the headset is bricked.  I can't connect it to my phone and it  doesn't recognize the controllers.  After spending half an hour on chat, the agent finally revealed that there is a known issue with controllers not connecting to the headset.  They had no solution to offer and told me they have no idea when this will be fixed, they said, and I quote "hopefully someday you will be able to use your quest again'.  the words 'hopefully' and 'someday' really grate, how can they be this incompetent?  I traded a headset with a dead pixel for a totally non functioning one.  Would love to know if anyone has found a workaround or if there is more info as to when this will be resolved. 


I have the same exact problem. Facebook is mocking me with procedures that don't apply to RMA units but to existing units. They're truly clueless. Also, it seems obvious now that they don't care about their customers. I sent them a unit with burnt pixels. IT WAS WORKING, just had burnt pixels. They made the problem worse by sending a non working useless solution. They're also refusing to ship a unit WITH factory paired controllers. Please explain how a company that makes BILLIONS per year refuses this? Is this what they have in store with their VR community - not give a rat's ar... about them?

Thank you Murdrrdbypirates and DominatorVIP - your procedures worked flawlessly!