cancel
Showing results for 
Search instead for 
Did you mean: 

Meta Quest Link is taking up 80% of my GPU

TIMOFEIKA
Explorer

Hello, I wanted to play some Blade and Sorcery 1.0 but for some reason I was getting 3 frames per second With Air link. I opened the task manager and realized oculus was taking 80% percent while the game was only taking 20%(Also happens with cable). And after I downloaded a mod that made Oculus not launch and instead Steam launched (With cable), the game worked perfectly fine. Why? Why is this? I've had problems before with Oculus (Too many problems) But nothing like this, If it wasn't for the fact I still have a quest 1 I would switch to steam link immediately. Anyways is there a fix to this?

12 REPLIES 12

TIMOFEIKA
Explorer

I also tried Virtual desktop And again no problems, This is exclusively a Oculus Problem.

MetaQuestSupport
Community Manager
Community Manager

Hey there, @TIMOFEIKA! We know how important it is to have the Oculus PC application run as optimally as possible, so we'd love to look into why it's GPU utilization is so high! Let's work together to get to the bottom of this! 

 

First, please provide us with the following:

  • Your video card model
  • Your processor model
  • Your OS
  • Is this issue isolated to Blade and Sorcery, or do you experience this issue with other apps or games?
  • Does the issue occur while inside of Oculus Home as well?
  • Any troubleshooting steps that you have tried so far, as we don't want to make you repeat things unnecessarily.

We look forward to hearing back from you!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

GTX 1660 S
Intel i5-9400F
Windows 11 23H2
I did experience it in other games as well, But most of them low graphics demanding games.
Yes, even with no games loaded.
I didn't try any troubleshooting steps, I just switched over to Virtual desktop and it works perfectly.

I also want to mention, that every time it gets used to a hundred percent there's this weird delay thing that happens on my screen, Like on the top left of my screen it's normal gameplay just a tiny bit delayed, And the rest of the screen is a delayed 3-20 fps mess.
I've done my best to recreate it: ss_c456350c35becb14063c53baa3e9d144d7e7f06eP.png

Thanks for getting back to us! We'd like to ask a few more questions to get a better idea of where to start troubleshooting. Would you please provide the following information:

 

  • Are both the headset and the desktop application up to date?
  • Have you updated your graphics card driver recently? (Sometimes being behind on a GPU driver update can cause reduced performance)
  • If you're able to, can you test the headset with another computer?
  • You mentioned a mod that you downloaded, was it from a bundle available on the store? (User created mods can sometimes cause reduced performance if it's not optimized properly)

We appreciate you taking the time to get this over to us, we're looking forward to your response!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Yes, Well I think. The quest has long been discontinued, But it did say it's up to the latest update
No. I was on the latest software for about a week and then suddenly this happened. (still no new update after as well)
Sadly I can't. I don't have anyone else that has a VR ready pc.
No it was from Github, I only got it after the desync started to happen. So it shouldn't have any correlation. Plus it was just a mod that we directs you to steam VR, it doesn't need any optimization.

Also any idea why it's not delayed in the top left and delayed everywhere else? (As you see in the previous picture I posted.) 

We appreciate you getting back to us with these details, @TIMOFEIKA. With this issue appearing after a recent update, we would like to have the PC app repaired to make sure everything is communicating properly. 

To do so, let's complete the following steps: 

  1. Download and run the Meta Quest Installation Software 
  2. You will see a screen which says "Already Installed".
  3. Click the "Repair" option, and confirm again on the next screen.

Once completed, do let us know how things appear when launching the PC app. While it is hard to narrow down why one part of the screen appears fine and the other not, we'll continue to gather more details to see how the PC app is functioning on the backend by possibly collecting your Logs or completing a clean installation of the PC software. Until then, we look forward to hearing how things appear!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

We noticed that we haven't heard back from you yet. If you still need help with this, please let us know. We're more than happy to continue looking into the matter together!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

TIMOFEIKA
Explorer

Ah yes sorry, I'm in the process of moving and haven't really gotten free time on my hands. I'll get on as soon as I get some free time. Once again sorry.

No worries at all! Moving is a time consuming process, and even if you have some time, things may not yet be set up to be able to test properly. Please reach back out once you have had a chance to test, and we will be happy to help!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?