Showing results for 
Search instead for 
Did you mean: 

My Oculus app will not let me purchase apps/games

Level 2

My oculus any time I try to buy something it has this pop up


Accepted Solutions

Hey there DowDAO! We hear you are having issues purchasing, and know that can definitely leave you feeling something. Let's see what we can do to help you.


If you trying to add a payment method, then we have a few things to try:


  • Try another web browser
  • Check to see if the financial institution placed any restrictions
  • Try another network connection type
  • Try another network location
  • Restart the device
  • Try another device
  • Try another payment method.
  • Clear cache and cookies on the browser

If you have tried all of these steps and you are still unable to add a payment method, Please reach out to us HERE.

View solution in original post


Level 2

I’ve added my PayPal account and a debit card, and when I go to purchase a game, it says ‘Sorry, something went wrong!’. Very frustrating!

Level 2


I’m having this same issue! So annoying!

Level 2

same problem 🙁

wanted to buy the electronic mixtape in beat saber, but i cant purchase 


currently going through this. Seen more people are as well.

Level 2

Same issue here.

I was having the same issue until I tried making the purchase from the store on It seems like the purchase has gone through but I've yet to try accessing it on my Q2. Wasn't able to purchase on the app or on the device before trying the desktop site shop. 

Worked for me too -
also I found an update to the Oculus app on my iPhone. After updating I can purchase games again.