cancel
Showing results for 
Search instead for 
Did you mean: 

My PC isn't showing up in Air Link

Zappyiscool
Honored Guest

I just bought a quest 2 and want to connect to my pc using airlink but whenever I got to use air link on my headset my pc wont show up for me to pair it. Any help is appreciated.

3 ACCEPTED SOLUTIONS

Accepted Solutions

Everybody, just to let you know please stop replying to this post, and I found a solution and I am late sorry about this but you just go to firewall and add a program and browse and then go in your oculus folder and go in the support folder and then search through the folders and you will find ovrserver, don’t worry there is not that much folders, hope this helps you!

View solution in original post

FunkyTanuki
Meta Quest Support
Meta Quest Support

Hey everyone, looks like the latest firmware update should've fixed this issue. Can anyone confirm that this is working as it should now?

If anyone is still having trouble with this issue, feel free to reach out to our support center so that our specialists can gather a bit more information from you guys. You can get there by using the following link

"I Have Found That People Lie, Most Often Deceiving Themselves. Not So The Dead. The Dead Are So Very, Very Loud. And Yet, Lying Is Not In Their Nature. It Is So... Humbling, To Listen To The Dead Speak."

View solution in original post

I don't know, if you are having the same issue as many users currently.

Try the steps @LaserDisk suggested in the following link.....it worked for me.

Solved: Re: Quest 3/ Air Link stopped working/ No connecti... - Page 8 - Meta Community Forums - 11... 

View solution in original post

86 REPLIES 86

MetaQuestSupport
Community Manager
Community Manager

Hi Zappyiscool! Let's work together to get Air Link working properly! We'd like you to follow these steps so we can establish a baseline of troubleshooting:

  • Go to the Settings menu inside your Quest 2 and toggle Air Link off.
  • Restart your headset by holding down the power button for 30 seconds, then turning it on again.
  • Close the Oculus PC app and restart your PC.
  • Turn Air Link back on and try again to pair your headset to your PC.
  • Ensure your PC and headset are connected to the same network.

Let us know how this goes for you. We'll for sure provide more help if you need it. Thanks!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Shozanahren
Explorer

I've had the same problem. Found it was caused by my router, which was on some paranoid settings to not let detecting devices on intranet. Paranoia is always good, so I let it be. Instead, I made a mobile hotspot from my notebook to directly link it with my headset. It worked perfectly, and without any interference of other network devices (which are many).

RudyvdLinden
Honored Guest

I just ran into this issue as well today, after having used it without issues for a long time.

 

Turned out for me it was Windows having set my network to public, thus my pc was not discoverable. Setting my network to private made my Quest 2 discover my pc again over Air Link.

MeekGroundhog21
Honored Guest

Same issue and found the solution go to windows security, under firewall & network protection click allow an app through firewall, there you have to check if OVRServer is allowed if not then allow it and voila its fixed

That is the one! Thank you! Wondering how you figured out that OVRServer belongs to the Oculus app...

XD YES! Turn it off, and back on again. 

Benzke
Honored Guest

That happened to me once. I just restarted my computer

Thank you, thank you and thank you. its been hours and days of trying stuff, reinstalling sotware and factory resets.

You are a genius

DragonSenpai126
Honored Guest

If you have ESET like i do, you can do the following steps that i took which ended up helping.

1. Check your Windows Defender and see if your options are grey.
2. If not grey find the "Allow an app through firewall" and put:
C:\Program Files\Oculus\Support\oculus-runtime\OVRServer_x64.exe in the box and attempt pairing to your computer.
3. If the options are grey then go to ESET and go to "Setup" then "Network Protection" go to "Firewall" then click "Configure..." go to "Advanced" then "Rules" and click Edit. Click "Add" on the bottom left.
The rule should go something like this:
Name: Oculus Services
Enabled: :heavy_check_mark:
Direction: Any
Action: Allow
Protocol: Any
Next go to Local and find "Application" and click the triple dots. Click the 3 "OK"s until you get the user consent interface and click allow.
4. Go to "Troubleshooting Wizard" under Network Protection", and unblock the following applications:
SSDP Discovery by Microsoft.
NT Kernel & System by Microsoft.
DNS Client by Microsoft.
If you see your router and ESET advised you being on a untrusted network,  Unblock it then go to "Connected Networks" under Network Protection. Click "Untrusted Network" on your Wired or Wireless connection. 
(ONLY DO THIS IF YOU ARE ON YOUR HOME WIFI) then click "Yes" to make it trusted.

Should be working now like it is for me.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?