Showing results for 
Search instead for 
Did you mean: 

New Quest 2 not pairing with app


Hi I just got a new Quest 2 for my birthday about a week ago and have been trying every single day to pair it with the app but it just doesn't work. I have tried multiple factory resets, two different phones. I've sideloaded the v43 update twice now and still no luck. Sometimes it automatically detects it and then just stops and the when I put in the code it says that It's already connected. I go into the app it says it was there but the headset is still stuck in pairing. Am I doing something wrong, is there a software issue or do I have to return it for a new one/refund.


Thanks, Look forward to a reply!



I've had an open ticket with Oculus support for a similar problem. I've effectively got a brick. 


My Quest 2 has been sat at this "Pairing" screen for 2 weeks now.


Problem 1, was that it's hardly been out of the box, so was running, which I gather to be "very old", I gathered this on the basis all the apps I had on the Quest failed to work anymore.


From within the UI, I was able to perform update, to 24.x.<something>.... this updated, but functionality did not return, and I was not offered any further update(s) from within the UI.


At this point, and we’re now at Problem 2. I hit the web and established even v24.x.x was old. So then I went off-piste, and sideloaded a full ~800MB file containing the V41 Firmware.


This resulted in the Quest receiving the new Meta boot logo, and prompting me to pair the device to my phone. Which just fails, it’s been failing for a week or more now. I've tried multiple WLAN connections, and multiple phones. The Quest sits at “downloading update 2 of 2 for a while, and sits at 0%” then after 30 minutes or so, makes what sounds like a success noise and this message switches to “Please pair your device with your phone”. I’ve never witnessed the bar moving from 0%, so I’m unsure if its timing out, or actually downloading.









Either way, my phone identifies the Quest 2 device automatically, but then informs me it still requires an update. So I’m now stuck, with a useless Quest 2.


At this point, feeling very annoyed by the whole thing, I then did what every IT guy loathes to do. I spoke to Oculus support. Their response suggested that the issue I'm facing is related to the recent switch to Meta auth, and that apparently, I'm not alone in facing this issue. However, I don't see anyone else having issues online across the usual channels.


The bottom photo is exactly what mine is doing its driving me crazy. My quest if basically useless


I found a copy of V43 "Full" and sideloaded this, performed a factory reset and now, after being stuck for 2/3 weeks, I can finally use my Quest 2 again.


Google: "v43 Update Zip File Available?", hit up Reddit.

Yeah I did all of that twice but it still wouldn't work so it's either the app or something wrong with the headsets hardware because surely other people have been able to pair otherwise they would be losing tons of money

Hey guys! Sorry for being so late, but I do want to share this is something that we've been seeing now for a bit with some people. 


We're in constant communication with our engineers at the moment to look for some possible resolutions for everyone that was afflicted. 


We thank you for the patience up to this point! 

Sometimes it's okay to be a little Bing Chilling

Some form of communication with the affected owners would also be appreciated. We are in limbo for weeks now without even knowing what to wait for as a solution! Should we be waiting for a new app version? A new firmware? Some fixes at the back-end servers?

I haven't been able to use my (NEW) Quest 2 for 2 weeks now, I have tried everything with no success. I want to be patient but I also need to know when I can finally use my fully paid device.


When will we know what to do?  Or do we keep opening tickets with support? 

Sideload v41, reset, then up to v43 again?


I've been using and developing for "Oculus for Business" (now Meta for Business) for the last 2 or so years, so was able to leverage some "higher up" support. That said, as soon as I mentioned sideloading to them, they basically washed their hands of me and said see what the support desk come back with. Which is fair enough, as its "unsupported".


That said, I had a brick, that I couldn't do anything with and wasn't confident/happy with the responses given by support, so went playing again myself (nature of the job!). Ultimately, I felt that if I could sideload a different version to what was installed, effectively forcing a full/total/reset I might be in luck. That seems to have been whats happened to me.


That said, you've said it's new, I guess you could always return it.


To be fair to Oculus support, the response given below by @TheAntiSocializer is what Oculus support told me, albeit 2 weeks ago. I don't know what they're waiting for, but given I've been waiting 2 weeks, the solution might not be a "quick one". (They said the reason was due to migration to Meta auth/accounts, but....)


I’m really not impressed I have a $400 paperweight and get the same support responses. @meta if you keep this up you will loose all your clients. Super annoyed