Showing results for 
Search instead for 
Did you mean: 

New Quest 2 not pairing with app


Hi I just got a new Quest 2 for my birthday about a week ago and have been trying every single day to pair it with the app but it just doesn't work. I have tried multiple factory resets, two different phones. I've sideloaded the v43 update twice now and still no luck. Sometimes it automatically detects it and then just stops and the when I put in the code it says that It's already connected. I go into the app it says it was there but the headset is still stuck in pairing. Am I doing something wrong, is there a software issue or do I have to return it for a new one/refund.


Thanks, Look forward to a reply!


I signed out of the devices, I did a fresh reinstall of the oculus software, I tried pairing the device on ethernet, on wireless, same networks both times. I logged out and logged back in, Apparently I can connect to pair to a strangers laptop two stories down, but I can't get it to pair to the software running 5 ft in front of me. The headset apparently can send a pair ping, but the oculus software I have isn't receiving it. I have updated all drivers, the software, windows. Nothing is working. 

Also I downloaded the software on the phone, couldn't detect the headset either, so something is wrong with the software on the headset. How do I factory reset it?


Okay, factory reset the thing, got to the pair the device and my phone and computer cannot detect the headset, even if it is plugged into the computer via usb and on the same wifi. Something is wrong with the wifi chip, how do I get this fixed?

Hi again! We're glad to hear that you were able to pair. At this time, we would like to gain some clarification by what you are meaning by the Wi-Fi chip?

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


I wasn't able to pair, I factory rest the device to see if it was an account or setting issue, but it required me to connect to the phone variant of the oculus meta application. I typed the 5 digit code into the phone, and the phone couldn't detect the headset, however, the computer it was plugged into changed its audio sources to the oculus headsets speakers and microphone. The computer can detect the headset, but the software is somehow unable to decern if the headset is on and active. So I am assuming something is wrong with the detection software or the chip itself that is causing the inability to connect.