Showing results for 
Search instead for 
Did you mean: 

New Quest 2 not pairing with app


Hi I just got a new Quest 2 for my birthday about a week ago and have been trying every single day to pair it with the app but it just doesn't work. I have tried multiple factory resets, two different phones. I've sideloaded the v43 update twice now and still no luck. Sometimes it automatically detects it and then just stops and the when I put in the code it says that It's already connected. I go into the app it says it was there but the headset is still stuck in pairing. Am I doing something wrong, is there a software issue or do I have to return it for a new one/refund.


Thanks, Look forward to a reply!


Honored Guest

Samedi problem , waiting for respons from support

Hi there! We would to assist you with this. We see you have been in need of support. At this time, we would like for you to reach out to our support team here for further assistance.



If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Great! Please resolve ticket 5499619

I’m having exactly the same issue. Feeling frustrated that they are taking so long to fix their mess up! 

I’ve had soooo many “oculus” support try to help. No u can’t sorry i need the real support  I will schedule a meeting with them. 

3 headsets and nothing!!! 


I genuinely believe here, that the issue of not allowing, or supplying users with the means to, officially perform "factory reinstalls" (Sideloading Firmware) is causing an unnecessary overhead on this problem.


I am having the same issue, however my quest 2 is easily almost a year old. I can't pair it to my pc, the pc application doesn't detect the headset. It ran just fine, but now it can't connect at all. I have tried every fix except a factory reset and at this point its Metas fault for whatever migration or update. Get it together and fix the headsets.


yeah so its a software issue that is happening to a lot of people, oculus wont help at all they will just tell u to go to the customer support, right now bro bro u gonna have to wait tell they get this fix, cause its not working for people that gets new headsets at all, 

Hey there @scottishlaw2020! That's not an experience we want to hear for our customers. We'd love to help you. 


We have a few steps to try as a workaround for your issue. can you please try the following:

  • Sign out of all of your devices
  • Can you uninstall the desktop and mobile and and then reinstall them
  • Can you go to on your mobile or desktop app and log out. Next, you can either log in with the Facebook or Oculus account you used to set up the headset or Meta account.

Let us know if this works for you. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!