cancel
Showing results for 
Search instead for 
Did you mean: 

(Not Resolved) Known Issue - Quest PCVR streaming micro lags and stutter esp. when moving head

acreed11
Protege

Hi team,

I'm getting micro lags and stutter in Airlink on my Quest 3 (EU/UK), esp. when moving my head. In the Oculus debug overlay this causes brief spikes in transmit/decode, fps drops and visible stuttering. The issue is not present on my Quest Pro with otherwise identical settings - see below screenshots to illustrate.

Few more details:
- Issue is not present on Quest Pro with same settings on HMD, router and PC (using same res)
- Issue is worse at higher bitrates, esp. >200mbps, but still present <200mbps
- Issue is unrelated to PC/game latencies (CPU, GPU, Queue each <5ms)
- Stutters/lags are intermittent (every 10-20 seconds) when not moving but happen immediately and reproducibly when moving the head to either side or especially looking downwards (i.e. on any bigger headset movements)
- Wifi 6E router (TP Link AXE75 EU/UK)
- EDIT: exact same issue with Asus RT-AXE7800 (EU/UK) wifi 6e router
- Connection shows as 2,400mbps
- Airlink codec H264 (but same on other codecs)
- I've attempted factory resetting, installing latest drivers
- Updated to v62 and latest Quest Link desktop version (I can see the 120hz option for my Q3)
- EDIT: Ordered a separate Quest 3 for testing: presents the exact same issue

-EDIT: Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

As the issue is worse the higher the bitrate and not present on Q Pro with otherwise same settings, I suspect it's related to the below known Wifi issues - but opening a new thread as instructed. 
https://communityforums.atmeta.com/t5/Get-Help/Known-Isssue-Unstable-wifi-coverage-with-Quest-3-on-s...

Best,
JensQ3Q3QProQPro

Updates:
- Tried separate router: exact same issue with Asus RT-AXE7800 wifi 6e router
- Ordered a separate Quest 3: exact same issue on both routers

-Same issue on 5ghz 802.11ax 160mhz BUT switching to 802.11ac (!) completely fixed the issue. I cant test this on 6ghz but looks like 802.11ax or something related to how q3 implements it is the culprit

281 REPLIES 281

Hey there, @Pantofli. We just so happen to be around and see that you are having some issues with your Quest Link and PCVR experience. We would love to assist you in resolving this issue and return you to enjoying the unique and special place known as virtual reality. First, can you answer the following questions so we can fully understand what's happening and the root of the problem?

  1. Have you always experienced this lag, and if not, when did it start?
  2. Does the lag stay present when you are using your Quest device in standalone mode or just PCVR?
  3. Have you tried using the Air Link, and if so, does the stuttering and lag stay present while you play?
  4. Are your PC drivers fully up-to-date, and have you upgraded your PC recently?
  5. Have you tried using another USB cable, and if so, does that help with the situation?
  6. Are you receiving any error messages when you start up your Quest Link, and if so, can you provide a photo of said error?

We appreciate your patience, and we hope to hear from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

1. It started about 1 week ago before that I didnt play VR for like 3 weeks.

2. Just PCVR

3. Ive tried Airlink and Im not sure if the problem is also there because I dont have 5ghz and then the connection is bad.

4. Yes and no

5. Yes, it didnt help.

6. I sadly dont get any error.

I have tried steam vr & use Virtual desktop not used the oculus software for streaming, but for me hands down for performance & visual quality virtual desktop is so much better than anything else currently available.

Having said that i cant say how well it will perform using your GPU.

One thing you have to consider is you cant have anything connected to the wifi channel you have your quest connected to be it 5ghz or 6ghz, if you have any other wifi devices connected, your quest will stutter, trust me i have researched & tested this myself.

hope you all get things working as i did somehow.

My PC:
CPU - Intel 12700k
GPU - Nvidia 4070 ti Super
Ram 32GB ddr4 @3200MT
Router - Asus ROG Rapture GT-BE98
Meta Quest 3 128GB connected via WIFI 6

Babinok
Expert Protege
After the recent update (v66), streaming PC games is completely over.
1) The headset stops detecting the PC via the airlink at least after every reboot of the headset, but now this happens even more often and without a reboot.
2) Switching the router to AC 160MHz mode no longer helps. Tracking lags appear in all modes, with all streamers (airlink, VD, steamlink) and with much greater intensity than before.
3) Before firmware 66, I could play with perfect picture quality and tracking through any of my 4 Type C cables. Now on each of these cables, airlink practically does not work; there are huge lags in image, sound and freezes when moving the head.
 
Since I don't play standalone games, the device is absolutely useless to me now and I feel cheated, I don't understand what I gave my money for. I strongly demand that you make it possible to roll back to older firmware (at least up to v56)!

snailbee0451
Honored Guest

I have the exact same experience, streaming used to work perfectly fine for me up until the v65 update. Now it's completely unusable, upgrading to an expensive WiFi 6E router did not help at all. Already contacted the developers of the Steam Link integration, they can't do anything about this. This up to Meta to fix.

Strongly agree with @Babinok , not offering any way of rolling back to working version should be illegal. You have made the product you sold unusable for a purpose that it was advertised for and are not even acknowledging it, even when there is a thread of 26 pages about it in your own forum.

 

ethan.vergara.125
Honored Guest

I honestly don't know why my Quest 3 is doing this but the only thing I can think of that has changed within 2 days is that when I booted up my headset to play i got the little white outline chip icon with a loading screen under it and suddenly the air link is terrible. I was using it not 2 days ago and it worked perfectly, I played for my two hours and got off, then today I spent about an hour trying to figure out why the thing was giving me the infinite black void with the weird reflection effect and basically being frozen. now granted I have to play in my basement because my room is a bit small and I have hit the walls and broken blinds when swinging my arms and moving around, and like i said this worked fine just a day ago, but even when trying to troubleshoot and test in my room where my Wifi is very strong it was giving me this issue, i was sitting at my computer and it was just frozen at the dash. Now I do also have a Link cable and while it was giving me some trouble still because despite being connected to my PC it wouldn't discover it for a bit, but once i got it connected it worked just fine with no freezing so it seems to be a problem with the Air link itself (Though granted just getting it connected even with the cable was a pain and i had to restart it twice until it worked, i got the "General headset Issue" icon a few times so that may also be part of it). Like I said the only thing I can think of that has changed since i last played it was that the headset seemingly went through an update, but IDK what exactly that chip icon means so it could mean it was going through a hardware check for all i know, it's not very clear.

Deviouz94
Honored Guest

Ive had this same issue for months now. Actually 6ghz band was never stable. Wireless PCVR is stuttering mess when using 6ghz connection. Router is TP-LINK AXE75 (eu). Only way to have a smooth experience is to use 5ghz band which has inteference and my bitrate is limited.

does anyone have any of ASUS tuf z690-plus motherboard or i7- 12700? My Windows is 10v.

I did not use my headset at all because i bought 3 routers and it does not change anything. My PC specs are decent so the only issue here is a headset. I only own it for 1 month but i am willing to sell it because it is completely useless for me since i bought it for PCVR.

A complete desperation. I can not even finish HL:A or play games like Beat Saber because of the stuttering. 

I bought multiple accessories, additional warranty and a lot of games in Steam and thats all went to waste 

Zombieyoda
Explorer

I have a z690 - a in my system.

Quick update, as of today the stuttering is back, nothing changed at my end , sad day.

Just going to update my display nvidia drivers to 556.12 to see if that fixes it .................

Apologies, seems the quest was downloading an update as i was playing, it didn't inform me, i only noticed when i went to check if there were any updates & noticed i had to restart to apply them.

Now working again.

Quest streaming is now broken again @72htz, 80htz, 90htz, 120 htz, all have random framerate drops of around 10FPS which induces stutter.

Looking at the VD monitoring tool , my network is solid, no spikes at all, however you can see the frame rate counter drop every so often.

My PC:
CPU - Intel 12700k
GPU - Nvidia 4070 ti Super
Ram 32GB ddr4 @3200MT
Router - Asus ROG Rapture GT-BE98
Meta Quest 3 128GB connected via WIFI 6

Gimpen
Explorer

 

I am having the same problems with Quest 3 128gb and the axe75 router, both bought and used in Europe with a PC using a 4090 and 13900k.

Everything worked perfectly on v62, now the connection speed drops when I move and even worse if I dont look at the router.

I do not know if this is related but also standalone games lag now (tried Vail and Asgards Wrath 2).

I cant use my device and it is getting really frustrating after this much time.

Quest is on v66 and router is on latest firmware.

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?