cancel
Showing results for 
Search instead for 
Did you mean: 

Not able to purchase any games

Anonymous
Not applicable

Just bought an Oculus Quest 2 yesterday, set it up and played around with some of the pre installed stuff and some free demos, but for some reason I'm not able to buy games on the store. I tried two different cards from different banks on the Oculus itself, the app and a desktop computer and none of them worked. The desktop and app both gave an error along the lines "something went wrong" and the Oculus told me that my bank needed further authentication and to check my email which i did and it just had a link back to the store and gave me the same error again. I also did not receive any messages from the banking app for either card asking me to authorise a payment. 

1 ACCEPTED SOLUTION

Accepted Solutions

Hello there, @kelton765432.2022. Being able to add a payment method is imperative to your overall VR experience. We want to ensure that you're able to add a payment so you can experience the games and apps you want. Payment matters are something that we take very seriously, and we always want to look into these issues thoroughly. With that being said, we ask that you please send us a PM so we can assist you further. To do so, please select our name to get to our profile page, or click here. Next, click "Send a Message" to privately message us! Please remember, you must be signed into the community first to send us a private message. We're eager to help, and we hope to hear from you soon!

 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

View solution in original post

66 REPLIES 66

karla.skizo
Honored Guest

Me too, I have the same problem. I put different cards and with my computer and the app and the web and always the same error.

skipshot2k
Honored Guest

Same experience here. I can't buy anything - not with paypal and not with CC.

MetaQuestSupport
Community Manager
Community Manager

Hi there, thezombywoof!

 

We want our users to be able to buy games easily, so we understand how this can be an inconvenience. This is a known issue that is actively being worked on. In the meantime, we do suggest following these steps:

 

  • If you recently made a successful online purchase from a US merchant, then check to see if your financial institution placed any restrictions
  • Try another network connection type
  • Try another network location
  • Try different combinations of the area/zip code
  • Restart the device
  • Try another device
  • Try another payment method.
  • Try another web browser
  • Try purchasing with the Oculus Home app (2D or 3D)

 

Please let us know if this helps, so that we can then look further into this issue if it still happens.

 

We appreciate you! Cheers!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hi, I have exactly the same problem and tried every single method proposed... it is really frustrating.

Hey fabioribeiro55. Being an avid gamers ourselves, we understand how frustrating it can be to not be able to purchase the games you want; please allow us to assist you with this. Seeing that you've attempted the above recommended options to no avail, we won't have you attempt them again. Please Click Here. It'll bring you to our support site. From there you can submit a support ticket. We offer email and chat support. From there, one of our trusted agents would be more than happy to assist you with this. No worries, we'll get you back up and gaming asap. We're here to help! 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thank you, but I managed to solve the problem and you can use this as a possible solution for the moment. The ONLY thing it is working now for the moment it is removing and adding your payment method again (debit card for me). If it doesn't work do it again, until it works. I did 2 times and worked.

I had to do this as well today.  I tried to buy a game from the Quest store with PayPal and it told me there was a problem with PayPal processing and to check this out with them.  I deleted my PayPal payment method but it would not let me add it again.  I then added a CC, then added PP again and changed it to preferred method. Then my purchase went through fine.  Seems to me that the oculus website is a bit buggy today.  I just tried logging into this forum and I needed to login to FB, then oculus:

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 6400 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro, Q3, w/Link and Air Link, Vive Pro1 with Etsy lens mod and Index Controllers

Hey man thanks for the feedback also. I was actually kinda concerned because when I had the error and starting searching for solutions, I was seeing that a lot of people were having the same issue, so I really got worried if I was gonna be able to buy anything for my vr haha. Gladly it worked now

BlindfEy333
Honored Guest

Same and I've reset my pin cause the original one doesn't work and I have been try to get a game for hour trying to reset it and still doesn't work

Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?