Showing results for 
Search instead for 
Did you mean: 

Oculus Go won’t charge, flashing red instead of orange or green.

My Oculus Go won’t charge or turn on. The dot that is supposed to be orange or green is flashing red,

Not applicable
Plug it in for a few hours after you have tested the cable and charger are charging ok on another device, the charger is 2 amp or more?

It’s the charger that came with it...

Sometimes it will stay orange for a while but won’t actually charge then goes back to flashing red...

Community Manager
Community Manager

Sometimes it will stay orange for a while but won’t actually charge then goes back to flashing red...

Hello there, if your
Oculus Go isn't charging with the charger it came with, please create
a support ticket at
so we can help you out. Thanks!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest
I had the same problem.  Hold down the power button for 20-30 seconds.  That fixed it for me.

Honored Guest

Ik this was a while back and you probably already either got a new one or got it repaired but I've had this problem with my aunts 2 oculus go's and it seems to happen when it looses some kind of connection between the remote and it at least that's what I think it is but how I fixed it was by finding a new cable or even the one that is making it flash red I unplug it plug it back in and continue and in-between the times I restart to plugging it back in I hold the power button down to see if it changes and If it does I reset it by holding down the power and (-) volume key and I mean a factory reset after it's starts charging and is at minimum of 50% then I factory reset it through the boot loader or what ever it is called then reconnect the headset to it's remote and app

I love how all these years later people are still using the Go and helping each other figure out these kinds of issues. Thank you.

You were absolutely spot on. My Go's LED was flashing green and refusing to turn on or charge. Plugging in the charger would show the expected orange light (solid) but this would only display for about 5 seconds, then revert back to flashing green.

The problem, as you suspected, was that the remote 3dof controller had no charge. I changed its battery and plugged the Go back into the charger and that successfully charged back up to full and turned on as normal. No need for any factory reset, for me at least.