Showing results for 
Search instead for 
Did you mean: 

Oculus Link cable disconnecting randomly


Hi I'm having a problem with the oculus link on the PC app. it keeps disconnecting randomly whenever I'm playing a PC game then takes me back to the oculus headset home screen and immediately connects again. I know its not the cable because I switched it out with an oculus brand one and It didn't help. I also confirmed that its not disconnecting from my pc just the app for some reason. I'm using a USB 3.0 port and have a kiwi link cable. I'm running
Oculus App Version (
Gforce Game Ready Driver Version 516.59
11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz 2.30 GHz
Nvidia GForce RTX 3060 laptop GPU


Honored Guest

I've had the same issue for months and it feels like i've tried everything. Some days are better than others. Sometimes it will be playable for 1 hour, others 5 min and then it starts to connect and disconnect repeatedly.

Community Manager
Community Manager

Hey there! We understand you're having a connectivity issue with your Link cable to the PC app. We know how annoying it can be when your gaming is interrupted by this disconnection, so we want to look into this further with you.


In order for us to assist you best, we'd like to ask that you gather your logs and submit them in a support ticket here. If you need the steps to collect your logs, they can be found in this support article. Please include the details of your issue along with your logs, and one of our agents will be happy to assist you further.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

have you found out any solutions yet 

Honored Guest

I get the same disconnecting problem with the latest 2 or 3 fw.

This happens only when using usb cable not wifi.

Wifi connection is fine.


not sure what is the problem because this was not happening when using older fw.

Hey there. Oculus link disconnecting constantly not an experience we want for our customers. We'd love to see what we can do to help you.


Can you please answer the following so we can customize troubleshooting for your issue:

  • Do you get any error messages?
  • Has this ever worked?
  • Is your PC compatible? (check here)
  • Do you see any bends, twists, cuts, frayed, ect. on the link cord.
  • Are you using the PTC for the Oculus link?

Once we have this information we can assist you with the best customer service. We look forward to hearing from you.


If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I also experience this problem.


I have Oculus 1 and a link cable. The cable is plugged into USB3. It works for a while, and sometimes disconnects. More recently, it has been frequently disconnecting and reconnecting. Feels like something is bugging it.


PC is compatible. Link cord is fine. I am using the approved link cable. (big thick black one)


Hope this helps.

Thanks for letting us know! I'd suggest PMing @MetaQuestSupport or reaching out by email and chat HERE. They can look into this deeper with you.

Genesis does what Nintendon't! Send me a DM if you have questions. I'm happy to help!