Showing results for 
Search instead for 
Did you mean: 

Oculus PC App won't install. NOT ENOUGH SPACE error.

Level 2

Trying to install the Oculus PC App on my laptop and keep getting the NOT ENOUGH SPACE on my PC error even though I have more than enough space to cover the 15.3 GBs required. What's going on and how can I fix this?


Community Manager
Community Manager

Hey there Singe69, thanks for reaching out to us about this! We understand device space is important, we'll do our best to get you back to enjoying all of your favorite VR experiences. The Oculus PC software installs to the C drive by default, although you can set a custom location for games and software. You'll need to either make sure you have enough space on your C drive to install the application or install it to a different drive. We've included some steps below on how to do this.


First, you'll need to make sure the drive you want to install the application on has sufficient free disk space and formatted to use the NTFS file system.


To install the Oculus app on a different system drive:


  1. Press the Windows key + R to open the Run command
  2. Enter the following path: [drive]:\Users\(Username)\Downloads\OculusSetup.exe/drive=[new system drive]Replace [drive] with the letter of the drive where Oculus was downloaded to.
  • Replace [new system drive] with the letter of the new drive you'd like to install Oculus to.
  • Examples:
  • C:\Users\(Username]\Downloads\OculusSetup.exe /drive:D
  • C:\Users\(Username)\Downloads\OculusSetup.exe /drive=D

3. Click OK.



The Oculus app will then open and attempt to install the app on the new drive you've chosen.


If you have questions about the steps above, please reach out to us! Cheers!

I understand that, but I still have 320GBs of space on my C:/ system drive; way more than the 15.3 required. I should be able to install the App.

Hey there Singe69, thanks for the response. We see there's still plenty of space to allow for the installation of the software. We'd like to ask a few questions to get a better idea of the situation.

  • Have you tried installing to another drive?
  • Is the drive you're attempting to install to formatted correctly? The drive should be 'NTFS' format.
  • Is the PC you're attempting to install to operating on Windows 11? Windows 11 is currently unsupported.
  • Please private message us your Oculus log files including setup logs so that we may look into them.

Once we receive this information we'll be able to better assist you. Cheers!


  • @MetaQuestSupport wrote:
    • Is the PC you're attempting to install to operating on Windows 11? Windows 11 is currently unsupported.


    It took me an hour to get here. Now it all makes sense. Windows 11 Update broke my Oculus. 

Hey there Tunichgud, we appreciate your response. Having your device unsupported by your operating system definitely is a bummer, and can set you back as you wait for the necessary support. Luckily, you have the option to revert back to windows 10 if it hasn't been more than 10 days since you installed Windows 11 and you took advantage of that free upgrade. You can achieve this by going into Settings > System > Recovery and choose “Go Back.” This will revert your computer to the Windows 10 version you had before installing Windows 11. If you revert to Windows 10, we recommend holding off on upgrading to Windows 11 until programs you frequently use support the new version of Windows.

Level 2

I have the same problem as everyone on multiple threads here.  Install in C doesn’t work and trying to shift to another drive (in NTFS format with a terabyte of memory ) gives an error message.  Followed the Oculus instructions and no joy.  Absolutely frustrating.  How is it that this PROBLEM was identified and noted 4 years ago and we all are here trying to find the right work around….  This is ridiculous…

I have the same issue with windows 10, not enough space although I have over 600Gigs available. Definitely an app issue

Hi, this is also a problem for me, i read all your reply to singh and compared it to mine, same as mine i have a lot of free space for the software, more than 15bg, my C drive is currently NTFS format, yet it still wont install, i tried to change the location but it always says location not found when i clearly have it

I got this resolved. Oculus doesn't recognize dynamic drives. You need to create a basic virtual drive. Reddit has clear instructions and has no impact to existing drives.