Showing results for 
Search instead for 
Did you mean: 

Oculus Quest 2 doesn't load anything

Honored Guest

Recently my headset stopped loading my apps and the store. My Facebook was logged out on the headset but connected on my oculus app. Bluetooth was still connected and nothing seemed to fix it. I tried multiple methods and nothing worked so I was forced to factory reset the Headset. It fixed the issue but in return I lost all of my saved data. It's so annoying that nothing worked and it happened out of nowhere. Is there anything I could've done or if it does happen again so I won't lose my saved data


Community Manager
Community Manager

Aww man! We're glad that you were able to get up and running, but losing saves on any device is rough. As anyone with a younger sibling can attest, we've all been there in some form or fashion.


Fortunately, there is a cloud back up feature that can be enabled. This will allow you to keep your saves, well, safe and minimize any potential losses of progress from all manner of unforeseen circumstances. The details can be found by following this link.


Your Meta Store Support team is always happy to help! If you find yourself in that kind of bind, reaching out with a chat or email is definitely an option. You can make that happen by following this link.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!