Showing results for 
Search instead for 
Did you mean: 

Oculus link is not supported by new RTX 3xxx ?




I am having problems with connection to my OQ 2. I read some replies that there is no update for nvidia RTX 3xxx and that Oculus link might not work or supported it yet. 


Today i bought a cable to try some games from PC or SteamVR but as a lot of people i have a 3 dots when trying to connect oculus link and after 15 sec i am back in main menu. All my drivers are updated. I tried to turn off overlay in nvidia experience. I changed the Encode resolution width to 2784. Running on 80 hz or trying 7x hz. Using USB-C connection is always fine and having 2.9 GBPs. Ofc restarting and resseting settings in Oculus or in the app tried. Device is always connected. 

Processor AMD Ryzen 7 5800H with Radeon Graphics 3.20 GHz
Installed RAM 16.0 GB (15.4 GB usable)
System type 64-bit operating system, x64-based processor
Nvidia RTX 3070 


So yeah i just wanted to see some offical respond if i should wait for some updates from Oculus software ? Because i read a lot of people have this problem. 



Are you using a 3.0 usb cable? if not that's the problem. 


secondly check if you plugged the usb cable into a 3.0 port. when I first tried the link cable I plugged it into a 2.0 slot and It would have the same issues as you stated.


lastly I'm using a RTX 3060ti and oculus link works fine.




Hello, yes i am using this one Anmiel oculus quest 2 link cable 6 m, USB 3.0 A to C. I have only 3.0 slots. 


I tried USB 3.0 to switch to different ports i got 3 and also used C. Still only 3 dots when i am trying to get in OQ 2. On the PC the game or any apps are running for example like google earth view or something and it seems like its moving already when i have my headset on but after 15 sec it goes back to menu. 


Yeah about the graphic card i just read couple threads that people are having issues with it dont know if its related. 

Honored Guest

Same setup here, tried reswet everything and reinstall Windows, Driver, Oculus Software. Got my Quest2 working on another 2 desktop pc. Just not working on my ASUS ROG Zephyrus g15 GA503QR laptop.

Windows 10 19042.985, Nvidia Driver 466.27, Quest 2 Software 286257504, Oculus App Version


Link (with official Link cable connected to my MB usb3.1 gen2 type-c port) and Air Link are both working great with my rtx3090.  Also with latest win10 feature updates and latest nvidia driver.  Sorry I cannot suggest anything except to contact Oculus support with your log files and see if they can identify the problem.  Good luck mate and cheers.

i9 13900K water cooled, RTX4090, Z790 MB w/wifi6e, 32Gb 5200 ram, 2x2TB SSD, 1000W PSU, Win 11, QPro w/Air Link, Vive Pro

Yeah thats what i ve send this morning logs etc. It seems the problem might be only on laptops maybe something to do with dedicated graphic cards even tho my settings for Oculus are for high GPU. We will see. Hopefully it can be sorted cause i would love to join on PC for better games. 

Honored Guest

Any Update on this? I have a similar issue.

my 3080 ti works just fine wired and air link.  But i have a pc.  I get 120 frames running at 1.4x.

Not really. Ive just updated my nvidia card but I havent tried oculus for last month. I ll maybe try to buy a new cable I ll post it here when I will have it and we will see.. 

I have the same exact issue with the same computer!