Showing results for 
Search instead for 
Did you mean: 

PC App can't reach Oculus Service

Honored Guest

I have checked all the other threads (the most recent being in February of this year) to try and figure out what is going on but nothing seems to work.


I updated my Oculus app today and it gives me the message "can't reach oculus service".  I have checked and my oculus runtime service is running.  I have tried using the repair tool to re-install and I have downloaded the installer again to try a completely fresh install.. no joy.


My OVRLibraryserviceLog says this
[Debug] [25/06/2021 18:17:50] Starting up OVRLibraryService v1.16.0.0.
[Debug] [25/06/2021 18:17:50] Starting up.
[Debug] [25/06/2021 18:17:52] IPC connection opened.
[Debug] [25/06/2021 18:17:52] App libraries for this user: [CORE_DATA]
[Debug] [25/06/2021 18:17:52] OVRLibraryService starting in service mode. Arguments: [migrate, enable-uwp]
[Debug] [25/06/2021 18:17:52] IPC thread running; waiting for Oaf to connect.
[Debug] [25/06/2021 18:17:52] IPC connection established!
[Debug] [25/06/2021 18:17:52] Creating NTFS transaction.
[Debug] [25/06/2021 18:17:52] Adding UWP permissions to Oculus directory.
[Debug] [25/06/2021 18:17:52] Committing changes.
[Debug] [25/06/2021 18:17:52] IPC connection destroyed.
[Debug] [25/06/2021 18:17:52] Exiting with code 0 (Success).



Community Manager
Community Manager

Hey! We'd like to check this out further. Please click here to submit a ticket and include your Oculus Diagnostics Logs in full. Thanks!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

Solved it myself, for those that come here with the same issue 2 things were required

1: Check the headset and the PC app have the same version (for some bizarre reason Oculus rolled out the update to the PC app before the rollout to the Headset was complete) 

2: If you have AMD hardware, version 21.6.1 breaks oculus link, roll back to 21.4.1 with this guide