Showing results for 
Search instead for 
Did you mean: 

PC Oculus Store issues, unable to download most past titles:

Level 7

For the past month I continue to have issues with downloading past titles. I have many great games I would like to play that state "Sorry we can't install ____ Please visit Oculus Support. I have done fresh installs, installed on a separate computer. Reset my network.  Nothing more I can do on my end. I also completed past support tickets submitting logs with no resolution. 


Anyone else going through this? I hope Meta updates the storefront and fixes these issues. Several hundred paid purchases since 2016 and most do not download. The storefront also has an issue where you are unable to download past titles (at least for me). It says get in text but no button to obtain, and no button on the actual page to purchase or download. Thank you. I am wondering if others are experiencing the same. I hate to make additional purchases and have them abandoned in the future with no ability to download. I will have to look towards other platforms if this isn't resolved. 


Accepted Solutions

Community Manager
Community Manager

Hi everyone! The team identified the issue that is preventing certain apps from being able to complete downloading and they are currently rolling out the fix gradually. This is happening slowly and I don't have a complete ETA for when it'll be deployed, but I'll let you all know when I've gotten the news that it's fully complete. 

For now, if you have a game that's not installing completely, I'd suggest a little patience and trying again later. 


Once again, our apologies for the inconvenience and we hope to get you back to gaming as soon as possible.


PS. I'm going to mark this post as the solution for this thread for visibility, but I'll let you know again when it's fully resolved for all titles.

Help others find great discussions and answers by adding kudos and marking solutions to your questions.

View solution in original post

501 REPLIES 501

Level 14


A few days ago I tried to install vader immortal

it threw up an error Sorry we could no install vader immortal please contact support...


So i did.

However I was able to install After the fall (after being unable to install vader immortal).

I did all the usual, turn off virus scanner etc.


Support asked me to uninstall my oculus software. I did this, and then hit the bug which you have just fixed (oculus software would not install).


Now i am back up with oculus installed....... however off all the software i have tried to install, only a few have worked

(luckys tale and city defender so far)


All of the others i have tried to install have given me the same error as above.... and now it included After the fall, which did previously install but is now not working.

please help, i have many £100s if not £1000s of software and none of it will install.  I have 3TB free on my drive (oculus installed to D)

I have had a rift or quest since 2014 and never had an issue before.




Not sure if it helps.  Whilst I cant install many of my titles fully (though a few work) it seems a lot of them DO work if i copy over my old install into the staging area, then hit install.  it verifies the existing files and then adds them to the manifest.

So the issue isnt an account permissions thing.


(before i uninstalled the old software i backed up all my installs as there were many 100s of GB worth).

Fiat Coupe, gone. 350Z gone. Dirty nappies, no sleep & practical transport incoming. Thank goodness for VR 🙂

Level 7

There are several other posts about similar behavior, you're not alone, Oculus support posted some responses to all the people with failed downloads of the Oculus app, but so far haven't really addressed all the people about game download failures afaik.


Any support tickets are not effective at this point, as they all assume user-side issues, whereas I believe this is server-side or at least Oculus-side. I've thrown everything but the kitchen sink at this problem from my end, I even went so far as to try other machine(s), and went to a friends house to attempt the download as well.


Has anyone else been able to download Elite Dangerous in the past 2 days? I've seen quite a few people mention they can't install Lone Echo but I'm not sure what else, some games download just fine.

I don't have that game but all the games released around the same time I am having issues with to download. If this isn't resolved I will no longer spend through the Oculus store, includes Quest 2. It's rediculous, who's to say Quest 2 titles won't go through the same next generations. Lesson for me is it's safer to purchase on steam. 

Level 7

It appears all titles over 1 gig fail to download. I set up a different PC, fresh install and other tips such as run as administrator, turn off virus protection etc. Also, as noted in a previous post "Cross buy" titles are greyed out with only text and no option to download. 


Can't download anything over 1 gigCan't download anything over 1 gigPXL_20211210_162612145_2.jpgStore View After the fall witin App.jpg

I'm not sure it's a hard cap, but it's different per title. On VPN I can get around 9gb of elite (sometimes), but it fails. Lone echo fails under a gig normally as well, but I downloaded moss and installed just fine (5gb)

Level 2

Same problem

super frustrating

tried all their suggestions - reinstall app, disable firewall etc but nothing works to enable larger game downloads to complete

Any other solutions?

Only other thing I can think of is VPN but it didn't work for me, got me a lot farther in the download but never 100%...ymmv

Tried VPN to France, Germany, UK and USA - any other countries that are “better”???

Honestly not sure, nothing worked 100%, maybe clear cache files and try VPN again. At this point I'm just waiting on a response from Oculus.