Showing results for 
Search instead for 
Did you mean: 

PC Oculus app can't reach Oculus service error


Hi Oculus/Meta,


This seems like a common problem for many people. I have the Rift and the Oculus app installed in my PC from 2017, I just bought the new Quest 2 this week. I removed the old Oculus app from my PC, and tried to install the latest Oculus app this time. Tried disabling my background apps of VPN and antivirus scanner. I keep getting this "Can't reach Oculus service" error. Tried Repair and Uninstall this app numerous time, still no success. Very frustrating. Might consider returning the new Quest 2 for a refund.


Community Manager
Community Manager

Hello edfoo! We see you are experiencing issues reaching Oculus service. We understand your frustration, especially since you just upgraded your device. Rest assured, we are here to help.


If you have not already, please reboot headset and make sure that the headset and computer are on the same network.


If you are still experiencing issues, please send us a support ticket, and we can assist you further!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Thanks for the reply. I am running a MESH home WiFi network using TPLink Deco M5. I tried to have both the Quest 2 and PC connected to the same mesh unit. I have tried rebooting the Quest 2 headset as you suggested. Seems like Oculus app has finished installed on the PC but every time I tried to run the app, it stuck on trying to "Checking the status of Oculus app" for a few minutes, then it errors out with "Can't reach the Oculus service".


I have saved a copy of the Setup log file.


Hey edfoo, 


We appreciate you for letting us know the troubleshooting steps you have taken to repair the Oculus Home application. For us to better assist you in this, please open a support ticket at including the log files of the computer you are using. 


To gather the logs: 

  1. Open the Run window (Windows key + R).
  2. Enter and run: C:\Program Files\Oculus\Support\oculus-diagnostics\OculusLogGatherer.exe
    • The above link is the default directory. Bear in mind that if you installed Oculus Home to another drive you will need to update the command with the correct file path.
  3. Select the checkbox next to ‘Full logs’.
  4. Select "1 day" from the "Collect last" drop down list.
  5. Wait for the log collection to finish. This can take some time to complete.
  6. The program will automatically generate a zip file containing your logs, which will be saved to your desktop automatically.
  7. Attach the newly created zip file to your next support response.

We look forward to working toward a solution together. 

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!


Been having the same problem for over a week now. Have tried every solution I could find in the forums. Still getting the same "Can't reach Oculus service" error. Frustrated to the point of returning this unit on Friday for a refund and buying the Valve Index (it's already in the shopping cart in the next tab). 

Hope you guys find a solution. I'm done wasting my time with this. No longer on facebook anyway. Later.

John 14:6   <--- (About 7 seconds after you clock out, you'll find out if Jesus meant what He said...)

Thanks for the reply. I have saved a copy of the Log file, now how and where do I attach it to?


Also I installed a copy of the Oculus app in my other older PC, and it ran fine, it did not have the "Checking the status of the Oculus app" windows at the beginning, it just launched immediately.


With my current PC, I also tried to run the Oculus Debug Tool in my C: drive, it shows the error message:

"Unable to connect to service. Unable to connect to service:

NotFound: Server endpoint not found Error code: -3003




This is a link to the log file in Zip format in my Google Drive:


Honored Guest

same problem for me  what i have to do ?


Honored Guest

[Debug] [10/02/2022 13:27:20] Starting up OVRLibraryService v1.16.0.0.
[Debug] [10/02/2022 13:27:20] Starting up.
[Warning] [10/02/2022 13:27:20] IPC connection attempt failed!
[Debug] [10/02/2022 13:27:20] IPC thread running; waiting for Oaf to connect.
[Debug] [10/02/2022 13:27:20] App libraries for this user: [CORE_DATA]
[Debug] [10/02/2022 13:27:20] OVRLibraryService starting in service mode. Arguments: [restart-service]
[Debug] [10/02/2022 13:27:20] Creating NTFS transaction.
[Debug] [10/02/2022 13:27:20] Waiting for service 'OVRService' to stop.
[Debug] [10/02/2022 13:27:20] Service 'OVRService' is now Stopped.
[Debug] [10/02/2022 13:27:20] Attempting to start service 'OVRService'.
[Debug] [10/02/2022 13:27:20] Service 'OVRService' is now Running.
[Debug] [10/02/2022 13:27:20] Committing changes.
[Debug] [10/02/2022 13:27:20] Exiting with code 0 (Success).