cancel
Showing results for 
Search instead for 
Did you mean: 

PTC v66 - Spatial data isn't saving in between game sessions

Lemonsquasher
Explorer

Every single Game/App is using wrong spatial data. Room, Boundary and Physical space adjustments do not matter. Then only way to get the proper spatial info, is by deleting all Spatial data and redoing a new ROOM from scratch then right after that the app will recognize the proper data! 

Later, if started again all is messed up height, orientation all screwed up. This happens with several titles, like FruitNinja, Spire, Stride etc ....

30 REPLIES 30

gaveitatry
Protege

I use Roomscale Boundary 100% of the time. I use Stationary Boundary (the circle guardian thing) 0% of the time.

Drawing my Roomscale Boundary takes time because I don't like to draw sloppily. And because I have to get my living room, kitchen, bathroom, and hallways in between. I also have to draw it carefully because I think that there is a limit to how big I can make the boundary. If I make certain areas too big, then I can't continue to draw in areas that I want to draw in. So I have to make sure I draw areas that are just the right size.

So anyway, let's say I have a Roomscale Boundary drawn and I've been using it for many months. Then let's say I enable the Lying Down mode. Then let's say I lie down and I press and hold the Oculus button until it has switches to the Lying Down mode. Then let's say I complete my gaming session. Now, let's say I sit back up and I press and hold the Oculus button again to switch it back to sitting/standing up mode. Now let's say I start a new game. For some reason, when I start the new game, it tells me that I can create a boundary, play in Lying Down mode, or use passthrough. If I select use passthrough, I can't play the game because I don't see the game, I just see passthrough. If I select Lying Down mode, then I can't play sitting up. So I have no choice but to select create a boundary. But when I do that, it is already in Stationary Boundary mode. If I switch to my desired Roomscale Boundary mode, I have to redraw the entire boundary.

So basically, I feel reluctant to even use the Lying Down mode, because it is a hassle to keep getting these prompts and to keep losing my Roomscale Boundary. Ideally, I wish I could just switch between sitting/standing and lying down as often as I want and never get prompted to redraw or create a boundary. I don't need prompts about passthrough modes, continuing to use Lying Down mode (when obviously I don't want to continue using it as I pressed and held down the Oculus button while sitting up), or get prompts to create boundaries. I want my Roomscale Boundary to never get deleted and for it to always be used once I am sitting/standing back up without me having to do anything.

If I am using Roomscale Boundary and I use Lying Down mode and then I go back to sitting/standing and pressing and holding the Oculus button, I want to be brought back to Roomscale Boundary instead of being forced in Stationary Boundary and told to create a new boundary.

 

Hey @gaveitatry. We see you're experiencing some issues with transitioning back into your boundary smoothly after using the laying down feature on your headset. We hear you, and we want to steer you in the right direction for this issue. We appreciate you bringing this to our attention so we can move the issue along to the proper channels to further look into what might be causing this to occur. Something we would also suggest is to check out our Ideas Forum by clicking here. This will allow you to connect with us and help us get a better grasp on fixing this issue and other bugs in our system that occur. We hope this was useful. We're here and open to assisting you if you have any further questions as well. Hope to hear from you soon!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Hello again! We wanted to follow up with you to see if there is anything else we can help you with and to remind you that you are always welcome to reach out to us again if you come across any other questions, and we will be happy to help!!  

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

I don't know why, but the way you worded everything makes me feel like this issue is just going to be ignored. I hope you understood the issue. I was really looking forward to Lying Down Mode. But when it arrived, I found that I completely lose my Roomscale Boundary settings after I am done using it and it doesn't make me happy to have to redraw it every time since it takes me a few minutes to redraw it each time. What have the developers said about this? Have they reproduced the issue? How soon do you think they will try working on it? The way I see it is if someone has a Stationary Boundary and they go into Lying Down Mode but then leave Lying Down Mode, they should automatically be in Stationary Boundary mode without any popup prompts. And the same thing if they were originally in Roomscale Boundary, they should return to Roomscale Boundary without any popup prompts and without having to redraw the entire boundary.

 

We definitely understand that your boundary created for gameplay has taken time to be drawn and switching to lying down mode is causing you to carefully redraw the boundary, delaying your start when hopping back into standard VR. While we do not have a timeline, on when updates will be provided to help make this transition a little easier for you, we have suggested sharing your thoughts in our Ideas Forum as our engineers are able to continue building future updates from your feedback. As we continue to make changes, we're truly excited about what the future holds, and the many adjustments to help make gaming easier!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

No. What you said isn't exactly accurate. my Roomscale Boundary is something that I use for all apps, not necessarily gaming. I don't draw the Roomscale Boundary before each time I play a game. That's 100% wrong. It takes me 5-10 minutes to draw a Roomscale Boundary. But Lying Down mode forces me to switch to Stationary Boundary two times (when I first start Lying Down mode and right after I leave Lying Down mode). And switching to Stationary Boundary deletes my Roomscale Boundary that I took 5-10 minutes to draw. So if I were to use Lying Down mode once a day, I would be wasting 5-10 minutes redrawing the boundary. If I were to use it four times a day, I would be wasting 20-40 minutes redrawing the boundary. Because of this, Lying Down mode is 1,000,000% unusable to me now. I was really looking forward to it, but it's been out for over a month and I can't even use it at all. I tried it twice, and both times, I was infuriated. I tried it the second time yesterday, after the Meta 65.0 update. Nope, it's still the same. So it was unusable for me in 64.0 and it's unusable for me in 65.0. And since no one has an ETA on when this will be changed, I could be looking at months, years, or (never) before it will be changed. What needs to change is that Roomscale Boundaries need to be SAVED. So if we switch to a Stationary Boundary and then switch back to Roomscale Boundary again, it should give us an option to APPLY OUR SAVED Roomscale Boundary so we continue using things before and not waste time walking around the house drawing stuff for 5-10 minutes. I tried using Lying Down mode last night after the 65.0 update, and it destroyed and erased my Roomscale Boundary. It was late and I was tired, so I just turned the headset off. I'm not looking forward to having to spend 5-10 minutes walking around my house today to redraw it. I will 100% NEVER EVER touch Lying Down mode ever again until you fix this. Because it is 1,000,000% unusable to me as it is right now. Imagine if someone was in a wheelchair and you kept forcing them to roll around their apartment or house redrawing the Roomscale Boundary over and over and over and over and over again, because you don't save it and you delete their Roomscale Boundary each time they use Lying Down mode. It's unreasonable.

 

Thanks for getting back to us, @gaveitatry. While our latest update has not addressed your boundary concerns, we do ask that a bug report be submitted for our team to continue investigating this further. Even though a time-frame can not be provided, do know we take your feedback into consideration when implementing new updates and improvements to our software, which is also why our Ideas Forum is so important to us as well to learn more about your experience.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Look. I'm not going to create a Bug Report from my VR headset. It's a lot harder to type using a controller and virtual keyboard than it is to type on my computer. I've submitted dozens of Feedback using that Report Form on the Quest 3, and not a single one has ever been addressed. Look at how much I typed in my last post. I'm not typing that all over again. I wish you could help, but I guess this is the extent of what you can do for me. I just hope SOMEONE... SOMEWHERE will get through to the right developers so this can be looked into.

 

Hey there, @gaveitatry! We definitely get not wanting to type out a long report using a controller! You don't need to use your headset to submit a bug report, that can be done through the mobile app as well using the instructions here.

 

Hopefully the developers will be able to replicate the issue you are reporting and get to working on a fix!

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!
Still need help?

Did this answer your question? If it didn’t, use our search to find other topics or create your own and other members of the community will help out.

If you need an agent to help with your Meta device, please contact our store support team here.

Having trouble with a Facebook or Instagram account? The best place to go for help with those accounts is the Facebook Help Center or the Instagram Help Center. This community can't help with those accounts.

Check out some popular posts here:

Getting Help from the Meta Quest Community

Tips and Tricks: Charging your Meta Quest Headset

Tips and Tricks: Help with Pairing your Meta Quest

Trouble With Facebook/Instagram Accounts?