Showing results for 
Search instead for 
Did you mean: 

Press oculus button but nothing happen (setup issue)

Honored Guest

So I have reset my quest 2 coz the **bleep** time & date settings were wrong all the time. Setup went fine until I get stuck at the last page where its tell you to " press the oculus button to get to the library/menu page" . Nothing happen when i pressed it. The button is working though cuz when u hold it it re-center the screen. I factory reseted it 3 times and its keep happening. I also googled it but no resolution. anyone had this issue?


Community Manager
Community Manager

Hi there! Thanks for sharing what's been happening with your headset. A very strange issue indeed, not too worry we have a few suggestions to try and get past this and access the game menu.


We can try and isolate the issue by trying to look at the controller first,


- Try to remove the batteries for at least 30 seconds and then try to unpair and pair the controllers once more.

- Clean your controller gently if possible.


You can also perform a factory reset by accessing the USB Update menu by doing the following,


  1. Turn off your headset.
  2. Hold the power and volume (-) button on your headset down simultaneously until the boot screen loads on your headset.
  3. Use the volume buttons on your headset to highlight Factory Reset and press the power button.
  4. Use the volume buttons on your headset to highlight Yes and press the power button.


Still, need help? Reach out to us here 👉🏻 and get in touch with our expert support line of assistance that's ready to help, they'll be able to offer some other options to get this solved.

If you're the author of a thread, remember to mark a reply as the Accepted Solution to help others find answers!

Honored Guest

I found the solution; once you have calibrated the screen, you need to click (not hold) the oculus button once to get to the library/menu page. 


I however noticed that while in game (Population One), I play a lot that game; my left joystick that I use to move forward/backward - left/right while in game, glitches, tried calibrating it but still the same issue, does that mean the left joystick is broken and I have to buy a new one or would you know what would cause this issue?

thank you